yarn babel-jest 26.0.0

latest releases: 28.1.0, 28.0.3, 28.0.2...
2 years ago

Features

  • [jest-environment-jsdom] [BREAKING] Upgrade jsdom to v16 (#9606)
  • [@jest/fake-timers] Add possibility to use a modern implementation of fake timers, backed by @sinonjs/fake-timers (#7776)
  • [jest-runtime] Add createMockFromModule as an alias for genMockFromModule (#9962)

Fixes

  • [babel-jest] Handle null being passed to createTransformer (#9955)
  • [jest-circus, jest-console, jest-jasmine2, jest-reporters, jest-util, pretty-format] Fix time durating formatting and consolidate time formatting code (#9765)
  • [jest-circus] [BREAKING] Fail tests if a test takes a done callback and have return values (#9129)
  • [jest-circus] [BREAKING] Throw a proper error if a test / hook is defined asynchronously (#8096)
  • [jest-circus] Throw more descriptive error if hook is defined inside test (#9957)
  • [jest-circus] [BREAKING] Align execution order of tests to match jasmine's top to bottom order (#9965)
  • [jest-config, jest-resolve] [BREAKING] Remove support for browser field (#9943)
  • [jest-haste-map] Stop reporting files as changed when they are only accessed (#7347)
  • [jest-resolve] Show relative path from root dir for module not found errors (#9963)
  • [jest-runtime] Fix absolute path moduleNameMapper + jest.mock bug (#8727)

Chore & Maintenance

  • [*] [BREAKING] TypeScript definitions requires a minimum of TypeScript v3.8 (#9823)
  • [*] [BREAKING] Drop support for Node 8 (#9423)
  • [*] Upgrade to chalk@4 (#9752)
  • [*] Remove usage of realpath-native (#9952)
  • [docs] Fix example reference implementation to use Jest with Phabricator (#8662)
  • [docs] Added default compiler to tranform (#8583)
  • [docs] Updated Testing Frameworks guide with React; make it generic (#9106)
  • [expect, jest-mock, pretty-format] [BREAKING] Remove build-es5 from package (#9945)
  • [@jest/fake-timers, @jest/environment] [BREAKING] Rename LolexFakeTimers to ModernFakeTimers (#9960)
  • [jest-haste-map] [BREAKING] removed providesModuleNodeModules (#8535)
  • [jest-runtime] [BREAKING] Remove long-deprecated require.requireActual and require.requireMock methods (#9854)

Don't miss a new babel-jest release

NewReleases is sending notifications on new releases.