yarn @angular/router 12.1.0-next.2
v12.1.0-next.2

12.1.0-next.2 (2021-05-19)

animations

| Commit | Description |
| -- | -- |
| e27ac018ed | fix(animations): ensure consistent transition namespace ordering (#19854) |
| 8ad90475e3 | fix(animations): update supported range of node versions to only include LTS versions (#41822) |
| a99aa29040 | fix(animations): allow animations on elements in the shadow DOM (#40134) |
| 547363a851 | feat(animations): update supported range of node versions (#41544) |

bazel

| Commit | Description |
| -- | -- |
| 6f0c7fb91c | fix(bazel): update supported range of node versions to only include LTS versions (#41822) |
| d583d926db | feat(bazel): update supported range of node versions (#41544) |

benchpress

| Commit | Description |
| -- | -- |
| 2e7eb270df | fix(benchpress): update the check for start and end events (#42085) |

common

| Commit | Description |
| -- | -- |
| 4bc3cf216d | feat(common): add URLSearchParams to request body (#37852) |
| 6b8baad940 | fix(common): add body as an optional property on the options of HttpClient.delete (#19438) (#41723) |
| 6e11febf60 | fix(common): add right ContentType for boolean values with HttpClient request body(#38924) (#41885) |
| bce3194f78 | fix(common): update supported range of node versions to only include LTS versions (#41822) |
| 1aebf165db | fix(common): viewport scroller not finding elements inside the shadow DOM (#41644) |
| e0250e567a | feat(common): update supported range of node versions (#41544) |

compiler

| Commit | Description |
| -- | -- |
| 3c726c3516 | fix(compiler): unclear lexer error when using private identifier in expressions (#42027) |
| abcd4bbfaa | fix(compiler): preserve @page rules in encapsulated styles (#41915) |
| 1758d02972 | feat(compiler): support directive selectors with attributes containing $ (#41567) |
| da6ed1562e | fix(compiler): strip scoped selectors from @font-face rules (#41815) |
| e9952dd7f9 | fix(compiler): update supported range of node versions to only include LTS versions (#41822) |
| 73824d5337 | fix(compiler): not generating update instructions for ng-template inside alternate namespaces (#41669) |
| 62e3f3279d | fix(compiler): non-literal inline templates incorrectly processed in partial compilation (#41583) |
| dde81ba0cd | perf(compiler): reduce amount of generated code for safe accesses and nullish coalescing (#41563) |
| 75cc8133ad | feat(compiler): update supported range of node versions (#41544) |
| e1a2930893 | fix(compiler): avoid parsing EmptyExpr with a backwards span (#41581) |
| ec27bd4ed1 | feat(compiler): support nullish coalescing in templates (#41437) |

compiler-cli

| Commit | Description |
| -- | -- |
| cd252b99fe | fix(compiler-cli): use '' for the source map URL of indirect templates (#41973) |
| 6eafaa7b5e | fix(compiler-cli): expose the linker as a Babel plugin (#41918) |
| 35450c78f7 | fix(compiler-cli): prefer non-aliased exports in reference emitters (#41866) |
| b9276eadae | fix(compiler-cli): update supported range of node versions to only include LTS versions (#41822) |
| c3a512a9e9 | fix(compiler-cli): match string indexed partial declarations (#41747) |
| 7744e1e673 | fix(compiler-cli): allow linker to process minified booleans (#41747) |
| fe5bf7f53f | fix(compiler-cli): autocomplete literal types in templates. (#41456) (#41645) |
| 1b43158af6 | fix(compiler-cli): do not error with prepocessing if component has no inline styles (#41602) |
| b7bd23817e | feat(compiler-cli): update supported range of node versions (#41544) |
| 1d12c50f63 | fix(compiler-cli): autocomplete literal types in templates. (#41456) |
| fab1a6468e | perf(compiler-cli): cache results of absoluteFromSourceFile (#41475) |
| c9aa87cec0 | fix(compiler-cli): show a more specific error for Ivy NgModules (#41534) |
| ffea31f433 | perf(compiler-cli): allow incremental compilation in the presence of redirected source files (#41448) |
| 7f1651574e | fix(compiler-cli): prevent eliding default imports in incremental recompilations (#41557) |
| 3e0fda96b8 | fix(compiler-cli): resolve rootDirs to absolute (#41359) |
| 6ba67c6fff | feat(compiler-cli): mark ability to use partial compilation mode as stable (#41518) |
| deacc741e0 | fix(compiler-cli): ensure the compiler tracks ts.Programs correctly (#41291) |

core

| Commit | Description |
| -- | -- |
| 4bc5b4d93b | fix(core): global listeners not being bound on non-node host elements (#42014) |
| a529d4f4f8 | fix(core): do not retain dynamically compiled components and modules (#42003) |
| 544e6a5ca1 | fix(core): invoke profiler around ngOnDestroy lifecycle hooks (#41969) |
| e387d22f83 | fix(core): AsyncPipe now compatible with RxJS 7 (#41590) |
| 9b4b281c52 | fix(core): handle multiple i18n attributes with expression bindings (#41882) |
| 6581a1b48d | perf(core): minor improvements to listener instructions (#41807) |
| af12d8deaa | fix(core): update supported range of node versions to only include LTS versions (#41822) |
| 18b33e79d3 | perf(core): avoid storing LView in ngContext (#41358) |
| e66a5fbca6 | feat(core): update supported range of node versions (#41544) |
| f7e391a912 | perf(core): optimize getDirectives (#41525) |
| a07f303708 | feat(core): introduce getDirectiveMetadata global debugging utility (#41525) |
| aa0e54fe97 | fix(core): error if DebugRenderer2.destroyNode is called twice in a row (#41565) |

elements

| Commit | Description |
| -- | -- |
| 2364f7c94a | fix(elements): update supported range of node versions to only include LTS versions (#41822) |
| 12fc08bf9c | feat(elements): update supported range of node versions (#41544) |

forms

| Commit | Description |
| -- | -- |
| a4ebe8656e | fix(forms): registerOnValidatorChange should be called for ngModelGroup. (#41971) |
| ff4f77b0b9 | fix(forms): update supported range of node versions to only include LTS versions (#41822) |
| a0006a6bfb | feat(forms): update supported range of node versions (#41544) |

language-service

| Commit | Description |
| -- | -- |
| 1be5d659a5 | fix(language-service): fully de-duplicate reference and rename results (#40523) |
| a86ca4fe04 | feat(language-service): Enable renaming of pipes (#40523) |
| c3990b4fd4 | fix(language-service): update supported range of node versions to only include LTS versions (#41822) |
| 86621bec58 | feat(language-service): update supported range of node versions (#41544) |
| de93a7a4bb | fix(language-service): resolve to the pre-compiled style when compiled css url is provided (#41538) |
| bd34bc9e89 | fix(language-service): bound attributes should not break directive matching (#41597) |
| 78236bfdca | fix(language-service): use script versions for incremental compilations (#41475) |
| c7f9516ab9 | feat(language-service): implement signature help (#41581) |
| 0f54d6c4a5 | fix(language-service): use 'any' instead of failing for inline TCBs (#41513) |

localize

| Commit | Description |
| -- | -- |
| 992c70df59 | fix(localize): relax error to warning for missing target (#41944) |
| 08ca922a68 | fix(localize): update supported range of node versions to only include LTS versions (#41822) |
| 590d4dd578 | feat(localize): update supported range of node versions (#41544) |

platform-browser

| Commit | Description |
| -- | -- |
| 96624b71a7 | fix(platform-browser): prevent memory leak of style nodes if shadow DOM encapsulation is used (#42005) |
| 8dd382eda5 | fix(platform-browser): update supported range of node versions to only include LTS versions (#41822) |
| ef0d1c3545 | feat(platform-browser): update supported range of node versions (#41544) |

platform-browser-dynamic

| Commit | Description |
| -- | -- |
| f259c246a6 | fix(platform-browser-dynamic): update supported range of node versions to only include LTS versions (#41822) |
| b714f7b931 | feat(platform-browser-dynamic): update supported range of node versions (#41544) |

platform-server

| Commit | Description |
| -- | -- |
| 1224726c42 | fix(platform-server): update supported range of node versions to only include LTS versions (#41822) |
| c901b4d11f | feat(platform-server): update supported range of node versions (#41544) |

router

| Commit | Description |
| -- | -- |
| 961296adf5 | fix(router): update supported range of node versions to only include LTS versions (#41822) |
| 6bceb709df | fix(router): Only retrieve stored route when reuse strategy indicates it should reattach (#30263) |
| a1b2718b92 | fix(router): recursively merge empty path matches (#41584) |
| c30b171d20 | feat(router): update supported range of node versions (#41544) |
| 44a7fae00f | fix(router): handle new navigations from a NavigationEnd event (#41262) |
| d28a391385 | fix(router): Remove information about attached component when deactivating route (#41381) |

service-worker

| Commit | Description |
| -- | -- |
| f3c2abec6c | fix(service-worker): update supported range of node versions to only include LTS versions (#41822) |
| fc597f1db5 | feat(service-worker): update supported range of node versions (#41544) |

upgrade

| Commit | Description |
| -- | -- |
| 7a4414401a | fix(upgrade): update supported range of node versions to only include LTS versions (#41822) |
| 98fc4f4b2f | fix(upgrade): preserve $interval.flush when ngMocks is being used (#30229) |
| beafa22de9 | feat(upgrade): update supported range of node versions (#41544) |

Breaking Changes

Minified UMD bundles are no longer included in the distributed NPM packages.

compiler-cli

Linked libraries no longer generate legacy i18n message ids. Any downstream
application that provides translations for these messages, will need to
migrate their message ids using the localize-migrate command line tool.

core

Angular no longer maintains support for node v10
Previously the ng.getDirectives function threw an error in case a
given DOM node had no Angular context associated with it (for example
if a function was called for a DOM element outside of an Angular app).
This behavior was inconsistent with other debugging utilities under ng
namespace, which handled this situation without raising an exception.
Now calling the ng.getDirectives function for such DOM nodes would
result in an empty array returned from that function.

Special Thanks:

Ajit Singh, Alan Agius, Alan Cohen, Alex Rickabaugh, Amadou Sall, Andrew J Asche, Andrew Kushnir, Andrew Scott, Aristeidis Bampakos, Ben Lesh, Bendik Skarpnes, Benjamin Kindle, Charles Lyding, Chau Tran, Cosmin Ababei, Daniel Díaz, David Shevitz, Dharmen Shah, Dmitrij Kuba, Dylan Hunn, Eduard Bondarenko, Emily Wenberg, Front-end developer, George Kalpakas, Georgii Dolzhykov, Gopal Jayaraman, Gourav102, Gérôme Grignon, Hugo Mejia, Igor Minar, Jesse Palmer, Jessica Janiuk, JiaLiPassion, Joey Perrott, JoostK, Julien Marcou, Kapunahele Wong, Keen Yee Liau, Kirk Larkin, Kristiyan Kostadinov, Lars Gyrup Brink Nielsen, Martin Sikora, Mathias Schäfer, Michael Hladky, Mikhail, Misko Hevery, MrJithil, Nishu Goel, Oluwole Majiyagbe, Paul Gschwendtner, Paul Muriel Biya-Bi, Pete Bacon Darwin, Pierre Portejoie, Renovate Bot, Richard Sithole, Sagar Pandita, Sam Severance, Sumit Arora, Talha Azhar, Teri Glover, Wojciech Okoński, Zach Arend, Zack DeRose, aschaap, cexbrayat, iRealNirmal, iron, jeripeierSBB, mgechev, nirmal bhagwani, pavlenko, profanis, rachid Oussanaa, sovtara, unknown, va-stefanek and wagnermaciel

latest releases: 12.2.0-rc.0, 12.1.4, 12.2.0-next.3...
2 months ago