pypi docker-compose 1.26.0

Features

  • Added docker context support.
  • Added missing test dependency ddt to setup.py.
  • Added --attach-dependencies to command up for attaching to dependencies.
  • Allowed compatibility option with COMPOSE_COMPATIBILITY environment variable.
  • Bumped Pytest to 5.3.4 and add refactor compatibility with new version.
  • Bumped OpenSSL from 1.1.1f to 1.1.1g.
  • Bumped certifi from 2019.11.28 to 2020.4.5.1.
  • Bumped docker-py from 4.2.0 to 4.2.1.

Bug fixes

  • Properly escaped values coming from env_files.
  • Synchronized compose-schemas with upstream (docker/cli).
  • Removed None entries on exec command.
  • Added distro package to get distro information.
  • Added python-dotenv to delegate .env file processing.
  • Stopped adjusting output on terminal width when piped into another command.
  • Showed an error message when version attribute is malformed.
  • Fixed HTTPS connection when DOCKER_HOST is remote.
latest releases: 1.27.4, 1.27.3, 1.27.2...
4 months ago