pypi cryptoadvance.specter 0.5.5
v0.5.5

Release notes:

  • Devices: Support Electrum wallet as a device (#222) (@stepansnigirev)
  • Devices: Support Generic device (usable for any PSBT compatible device not directly supported in Specter) (#221) (@stepansnigirev)
  • Bugfix: Fix crash when creating a transaction from wallet with a device with type "Other" (#221) (@stepansnigirev)
  • Bugfix: Fix crash when adding keys to an existing device (#221) (@stepansnigirev)
  • Bugfix: Show proper error messages when combining PSBTs fails due to server error (#221) (@stepansnigirev)
  • Bugfix: Fix wallet behavior when passing a finalized transaction in signing page (#221) (@stepansnigirev)
  • Bugfix: Fix signature counter displaying wrong number (#223) (@stepansnigirev)
  • Bugfix: Fix PSBT xpubs derivation endian format (#232) (@stepansnigirev)
  • Bugfix: Fix crash if Bitcoin Core connection fails (#231) (@stepansnigirev)
  • HWI: Prepare support for Trezor and KeepKey multisig change address verification by adding xpubs data to PSBT sent to HWI (#232) (@stepansnigirev)
  • HWI: Add toggle passphrase support for Trezor and KeepKey devices (#234) (@ben-kaufman)
  • Feature: Export wallet to allow importing it to Specter or other supported wallet softwares (#220) (@ben-kaufman)
  • Feature: Import wallet from Specter or other supported wallet softwares (#225) (@ben-kaufman)
  • UI: Improved amount validation in new transaction screen (#221) (@stepansnigirev)
latest releases: 1.0.0, 0.11.0rc6, 0.11.0rc5...
6 months ago