npm mini-css-extract-plugin 1.0.0
v1.0.0

BREAKING CHANGE

  • minimum supported Node.js version is 10.13.0
  • the esModule option is true by default, you need to change const locals = require('./styles.css')/require('./styles.css') on import locals from './styles.css'/import './styles.css''
  • the moduleFilename option was removed in favor the filename option
  • the hmr option was removed, HMR will work automatically when HotModuleReplacement plugin used or webpack-dev-server with enabled the hot option
  • the reloadAll was removed

Features

  • the chunkFilename option can be a function for webpack@5

⚠ NOTICE

To avoid problems between mini-css-extract-plugin and style-loader because of changing the esModule option to true by default we strongly recommend upgrading style-loader to 2.0.0 version.

latest releases: 1.2.1, 1.2.0, 1.1.2...
21 days ago