- Public API no longer is a function, instead exposes two functions, mock and get
- Drop support for Node.js versions less than 4.0
- Rename asPositiveInt to asIntPositive
- Rename asNegativeInt to asIntNegative
- Rename asStrictBool to asBoolStrict
- Add asFloatPositive and asFloatNegative
- Add asUrlString and asUrlObject
- Refactor code with consistent errors and structure
- Use standard for code quality and formatting