npm @vue/cli-service 4.5.9

latest releases: 4.5.17, 5.0.4, 4.5.16...
18 months ago

This version updates the Cypress plugin, allows users to update to a new version of Cypress on their own.
Due to backward compatibility concerns, @vue/cli-plugin-e2e-cypress 4.x always comes with a Cypress 3 dependency, and won't be updated until CLI v5 releases.
But now that Cypress has shipped several new major versions in the past year, bringing many interesting new features such as cross-browser testing, you may want to try out a new version. As of this release, there now are 2 ways to update the Cypress dependency in the project:

  1. (Yarn users only) Add a resolutions field in the package.json:
{
  "resolutions": {
    "cypress": "^5.6.0"
  }
}

Then run yarn again to install the new dependencies. This will keep exactly one Cypress copy in the project so it's the recommended approach.

  1. Ensure you are on @vue/cli-plugin-e2e-cypress 4.5.9, then run npm install -D cypress or yarn add -D cypress in the project.
    This will install the latest Cypress version to your project root, and the Vue CLI plugin will refer to it when executing the test:e2e task.
    A drawback of this approach is that cypress@3 will still be downloaded during the dependency installation process, even it's useless now. Though, it is only a temporary problem as we are trying to keep the plugin's backward compatibility, and will be soon fixed with an upcoming v5 release.

🚀 New Features

  • @vue/cli-plugin-e2e-cypress

Committers: 1

Don't miss a new cli-service release

NewReleases is sending notifications on new releases.