npm @twind/preset-tailwind 1.0.0-next.35

latest releases: 1.1.4, 1.1.4-next-20230124084504, 1.1.3...
2 years ago

all packages have been updated to version 1.0.0-next.35

@twind/preset-tailwind

  • BREAKING: rename enablePreflight to disablePreflight to make it more clear what this option is used for and what its default is (53058c2e)

@twind/tailwind

  • DEPRECATE: @twind/tailwind — use @twind/preset-autoprefix and @twind/preset-tailwind directly (47ed17b3)

    Adjust your package.json:

    {
      "dependencies": {
    +    "@twind/preset-autoprefix": "1.0.0-next.34",
    +    "@twind/preset-tailwind": "1.0.0-next.34",
    -    "@twind/tailwind": "1.0.0-next.34",
      }
    }

    If you are using defineConfig from @twind/tailwind:

    -import { defineConfig } from '@twind/tailwind'
    +import { defineConfig } from 'twind'
    +import presetAutoprefix from '@twind/preset-autoprefix'
    +import presetTailwind from '@twind/preset-tailwind'
    
    export default defineConfig({
    +  presets: [presetAutoprefix(), presetTailwind()],
      /* config */
    })

    If you are using setup from @twind/tailwind:

    -import { setup } from '@twind/tailwind'
    +import { setup } from 'twind'
    +import presetAutoprefix from '@twind/preset-autoprefix'
    +import presetTailwind from '@twind/preset-tailwind'
    
    export default setup({
    +  presets: [presetAutoprefix(), presetTailwind()],
      /* config */
    })

@twind/with-next

  • add Next.js integration and example (df5fc751)

@twind/with-remix

  • add remix integration and example (98688bcb)

@twind/with-sveltekit

  • BREAKING: use new @twind/with-sveltekit package name (60db0177)

Don't miss a new preset-tailwind release

NewReleases is sending notifications on new releases.