npm @polkadot/api 3.2.1
v3.2.1

Upgrade priority: Low. Recommended for users of parachains.

Contributed:

Changes:

  • Add api.{errors, events, query, tx}.<section>.<name>.is(...)
  • Remove support for staking pre Substrate 2.0
  • Add all frontier types & RPCs
  • Support AccountInfo with new provider/consumer refCount structure
  • Additional Cumulus parachain types
  • Consistently format number JSON based on bitLength
  • Cleanup metadata -> api dependencies
  • Update @polkadot/util to 5.2.1
latest releases: 4.13.2-9, 4.13.2-8, 4.13.2-7...
5 months ago