npm @polkadot/api 2.6.1
v2.6.1

Upgrade priority: Low. Should be done alongside an update to @polkadot/util to 4.0

Changes:

  • Adjust auto-gas to contract RPC call to 5 * 10 ^ 12 (align with Rust)
  • Adjust derive AccountId check to take Ethereum-compatible chains into account
  • Fallback for chains with invalid council proposal data in derives
  • Bump static v12 Metadata (tests) to latest Substrate version
  • Bump @polkadot/{util,util-crypto} to 4.0 (optimized WASM layers)
latest releases: 4.14.2-5, 4.14.2-4, 4.14.2-3...
7 months ago