npm @polkadot/api 2.1.1
v2.1.1

Upgrade priority: Low.

Contributed:

Changes:

  • Adjust RPC error formatting with string cleanups and a larger allowed range
  • Apply limit protection on Text & Bytes, protecting against OOM on erroneous decoding
  • Add derive.staking.validatorsFrom to determine validators nominated and own validators
  • Cleanup document generation without (currently unused) summary links
  • Rename static TRANSACTION_VERSION to EXTRINSIC_VERSION (Substrate alignment)
  • Bump Substrate metadata (tests, doc generation)
latest releases: 4.13.2-9, 4.13.2-8, 4.13.2-7...
8 months ago