npm @polkadot/api 1.33.1
v1.33.1

Upgrade priority: Low. Recommended when using clones instances.

Changes:

  • Allow paymentInfo on any extrinsic with tx.paymentInfo(<address>, <at>) (hash specified)
  • When cloning an API instance the runtimeChain is now properly set from source
  • When cloning an API instance the registry is shared with the source
  • Optimize derive receivedHeartbeats to not re-create the full object
  • Add staking.stakerPrefs derive to retrieve validatorPrefs over a range of eras
  • Basic map of Websocket error codes to short descriptions (where none available)
latest releases: 4.13.2-11, 4.13.2-10, 4.13.2-9...
9 months ago