npm @ngx-loading-bar/core 5.0.0
v5.0.0

latest releases: 6.0.2, 6.0.1, 6.0.0...
2 years ago

Bug Fixes

  • 🐛 prevent start when the timer is not triggered yet (88f5254), closes #143

Features

  • core: change bar and spinner selector + unset z-index when fixed is false (#159) (f1ad7a8)
  • core: set peerDependency to angular >=9.0 (185f1e2), closes #151
  • core: support managing multiple loading bars (c59863f), closes #121
  • core: use OnPush change detection (47d8cff)
  • 🎸 remove deprecated @angular/http package (#139) (666e341)

⚠ BREAKING CHANGES

  • core: The library now requires Angular 9

  • core: The loading bar internal selectors have been changed:

Before:

<ngx-loading-bar>
  <div id="loading-bar-spinner"><div class="spinner-icon"></div></div>
  <div id="loading-bar"><div class="bar"><div class="peg"></div></div></div>
</ngx-loading-bar>

After:

<ngx-loading-bar>
  <div class="ngx-bar"></div>
  <div class="ngx-spinner"><div class="ngx-spinner-icon"></div></div>
</ngx-loading-bar>

Don't miss a new core release

NewReleases is sending notifications on new releases.