npm @graphql-codegen/typescript-resolvers 1.16.0
v1.16.0

Come talk to us directly on our Discord channel
Contact us here: the-guild.dev

core / cli

  • Update typescript-eslint monorepo to v3.5.0 (#4304) @renovate
  • Update dependency @types/js-yaml to v3.12.5 (#4288) @renovate
  • Update dependency graphql to v15.2.0 (#4210) @renovate
  • Update dependency flow-parser to v0.128.0 (#4298) @renovate
  • Fix DeclarationBlock to omit the semicolon for functions (#4294) @Zhouzi
  • Update dependency @oclif/command to v1.7.0 (#4302) @renovate
  • Update dependency nock to v13 (#4300) @renovate
  • Update dependency flow-bin to v0.128.0 (#4299) @renovate
  • Update dependency eslint-plugin-import to v2.22.0 (#4297) @renovate
  • Update graphql-tools monorepo to v6.0.11 (#4293) @renovate
  • chore(deps): update dependency @types/jest to v26.0.3 (#4285) @renovate
  • chore(deps): update dependency @types/lodash to v4.14.157 (#4286) @renovate
  • Update dependency @vue/composition-api to v0.6.7 (#4283) @renovate
  • Update dependency @types/react to v16.9.41 (#4282) @renovate
  • Update dependency @types/react to v16.9.40 (#4280) @renovate
  • Update dependency @types/jest to v26.0.1 (#4279) @renovate
  • Update dependency @types/react to v16.9.39 (#4277) @renovate
  • Update dependency jest to v26.1.0 (#4276) @renovate
  • Update dependency eslint to v7.3.1 (#4274) @renovate
  • Update typescript-eslint monorepo to v3.4.0 (#4271) @renovate
  • Update dependency jest-junit to v11.0.1 (#4270) @renovate
  • Update dependency ts-jest to v26.1.1 (#4267) @renovate
  • Update dependency @docusaurus/core to v2.0.0-alpha.58 (#4254) @renovate
  • Update dependency @docusaurus/preset-classic to v2.0.0-alpha.58 (#4255) @renovate
  • Update dependency @types/lodash to v4.14.156 (#4266) @renovate
  • Update dependency @vue/composition-api to v0.6.6 (#4265) @renovate
  • Update dependency jest-junit to v11 (#4262) @renovate
  • Update dependency eslint to v7.3.0 (#4261) @renovate
  • Update dependency @vue/composition-api to v0.6.5 (#4259) @renovate
  • Update dependency moment to v2.27.0 (#4257) @renovate

c-sharp / c-sharp-operations

  • Added nested array support (eg [[[String]]]) (#4296) @cklam2
  • Dropped assigning default values (#4296) @cklam2
  • Mark fields with default value optional, even when it had a ! (see #4273) (#4296) @cklam2
  • Generate C# interface from gql interface (#4296) @cklam2
  • If request doesn't have input args, don't include the variable arg in Request (#4296) @cklam2
  • Solved circular dependency issue (#4296) @cklam2
  • C sharp operation request and summary (#4284) @cklam2
  • C sharp operations improvements (#4264) @cklam2
  • C sharp reserved keywords (#4250) @cklam2

typescript-resolvers

  • Allow to customize the Resolvers suffix for each type resolvers type (#4292) @dotansimha
  • Allow to customize the root exported Resolvers type name (#4292) @dotansimha
  • Added support for namespacedImportName for typescript-resolvers plugin (#4289) @dotansimha

flow-operations

  • Fix bug with flow-operations codegeneration and flattenGeneratedTypes config (#4287) @ganemone

react-apollo-offix

  • dont generate fragments because they already come from typescript-rea… (#4275) @auryn31

typescript-generic-sdk

  • Allow use of Observables on subscriptions (#4204) @onhate
latest releases: 2.3.2, 2.3.1, 2.3.1-alpha-143b4bc91.0...
15 months ago