npm @angular/cli 11.0.0-rc.0

latest releases: 18.1.0-next.0, 18.0.2, 18.0.1...
3 years ago

Commits

@angular-devkit/build-angular (0.1100.0-rc.0)

Commit Description Notes
don't add publicHost pathname to sockPath in dev-server
update resolve-url-loader to version 3.1.2
add a base href to karma debug context [Closes #19116]
don't set watchOptions in webpack-middleware
disable dev-server live-reload when using protoactor
correctly reference hmr-accept.js file in windows error [Closes #19099]
ensure correct SRI values with differential loading [Closes #18254]
set HTML lang attribute when serving [Closes #18094]
override already existing assets in compilation [Closes #18787]

@angular-devkit/build-optimizer (0.1100.0-rc.0)

Commit Description Notes
support jit mode guarded class metadata removal

@angular-devkit/core (11.0.0-rc.0)

Commit Description Notes
allow prompt providers to access property types

@angular-devkit/schematics (11.0.0-rc.0)

Commit Description Notes
show active package manager with install task

@angular/cli (11.0.0-rc.0)

Commit Description Notes
use newer update command if global version is newer
coerce prompt answers to requested property types
skip searching deprecated packages with ng add
include deprecated option in JSON help
add missing dev-server `headers` option in IDE schema

@ngtools/webpack (11.0.0-rc.0)

Commit Description Notes
improve bad component resource error message
support jit mode guarded class metadata removal

@schematics/angular (11.0.0-rc.0)

Commit Description Notes
add migration to remove rebaseRootRelativeCssUrls from workspace config
add generation for resolvers
remove lint fix default value [Closes #19169]
allow inlineTemplate/inlineStyle with minimal application [Closes #17528]

Breaking Changes

@angular-devkit/build-angular: remove deprecated browser build option rebaseRootRelativeCssUrls (7535f4f)

Deprecated `rebaseRootRelativeCssUrls` browser builder option has been removed without replacement. This option was used to change root relative URLs in stylesheets to include base HREF and deploy URL and was used only for compatibility and transition as this behavior is non-standard.

(cherry picked from commit 981b4bb)

@ngtools/webpack: remove support for TypeScript 3.9 (0296f0f)

TypeScript 3.9 is no longer supported, please upgrade to TypeScript 4.0.

(cherry picked from commit 21351dc)

@angular-devkit/build-angular: remove support for TypeScript 3.9 (af4620a)

TypeScript 3.9 is no longer supported, please upgrade to TypeScript 4.0.

(cherry picked from commit f4c481d)


Special Thanks

Alan Agius, Renovate Bot, Charles Lyding, Doug Parker, Keen Yee Liau, Jaime Oliveira, Jefiozie

Don't miss a new cli release

NewReleases is sending notifications on new releases.