Fixes
- Fix sudo elevation in terminal always asking for a password
- Fix paths containing a tilde not being resolved properly for SSH
- Fix username detection failing on systems without the id command
- Fix SSH ProxyJump connections not using local config correctly
- Fix winget updater not working
- Fix SSH config parsing for Include directives, quoted values, and key=value syntax
- Fix network scan failing to parse some nslookup outputs
- Fix serial connection parity settings not being applied properly
- Fix Tailscale integration failing when no other devices are in the tailnet
- Fix Podman quadlet restarts not working for rootful containers
- Fix Proxmox container IP detection picking loopback or IPv6 addresses
- Fix Proxmox VNC setup modifying snapshot sections and adding duplicate arguments
- Fix file browser write permission check failing for some files
- Fix KeePassXC integration freezing when KeePassXC is not responding
- Fix API shell sessions not being managed properly for concurrent requests
- Fix adding SSH config entries for external tools removing other host entries from the user SSH config file
- Fix connection default actions not updating when a tunnel is started or stopped
- Fix Kubernetes contexts not being listed when no current context is set
- Fix SFTP errors for VM connections not being shown
- Fix first SSH connection after startup on Windows failing when the installation path contains spaces or special characters
- Fix MCP run script tool not finding the script and requiring optional arguments
- Fix file browser listing failing for some symbolic links
- Fix file browser showing wrong times for PowerShell systems
- Fix file transfer rename all choice also renaming files without a conflict
- Fix terminal multiplexer sessions not being tracked properly with multiple panes and a slow multiplexer start opening a second instance
- Fix Warp terminal failing to open on Linux for some paths
- Fix user SSH config options, e.g. ForwardAgent, not being applied for connections using jump servers
- Fix renaming vault users and roles not working
- Fix SFTP symbolic link creation using the wrong argument order
- Fix file browser directory sizes not working on BSD-based systems
- Fix file transfers possibly hanging after a connection loss
- Fix Wake-on-LAN not working on some systems and for MAC addresses written with dashes
- Fix Hyper-V VMs with multiple network adapters getting an invalid IP address
- Fix Webtop Proxmox containers ignoring the locale setting
- Fix RDP file import not handling IPv6 addresses
- Fix RDP gateway not working for associated hosts
- Fix RDP and VNC quick connect not using the default port
- Fix Remmina custom options not being applied properly
- Fix KeePassXC custom location being lost
- Fix HTTP errors without a response body not being shown properly
- Fix sessions of dependent connections not being closed when a connection is edited or deleted
- Fix various NullPointers
Changes
- Improve git vault commit signing to properly support SSH signing keys
- Show the public key for SSH config connections that use an identity file
- Improve network scan to work on more systems
- Improve confirmation dialog for actions launched from URLs
- Custom service commands now use $ADDRESS instead of $PORT as a placeholder to allow for more flexibility
- Prevent script URL and git sources with the same file name overwriting each other (This might require a script source refresh)
- Improve TigerVNC support on macOS
- Unavailable workspace dirs are now kept and shown as unavailable instead of being removed
Downloads
You can find all downloadable artifacts below attached to this release. For installation instructions, see the installation guide.
All artifacts are signed by Christopher Schnick (BBDA 885A DD3E 0AD0)