[built-in-ai]Rename canDetect() to languageAvailable()
This CL renames canDetect() to languageAvailable() in the new API, while
keeping the older version as is.
Bug: 372311602
Change-Id: I2f77b40cb9b30bb22b2ee3d083ec116c0e2cc635
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/5945483
Reviewed-by: Fergal Daly fergal@chromium.org
Commit-Queue: Yuzu Saijo yuzus@chromium.org
Cr-Commit-Position: refs/heads/main@{#1371224}