github vuejs/eslint-plugin-vue v7.0.0-beta.1

✨ Enhancements

New Rules:

  • #1267 Added vue/v-for-delimiter-style rule that enforces which delimiter (in or of) should be used in v-for directives.

Other changes in Rules:

  • #1259 Added allowProps option to vue/require-explicit-emits rule.

🐛 Bug Fixes

  • #1258 Fixed false negatives of "slot-scope" when "^3.0.0" is set in vue/no-unsupported-features rule.
  • #1262 Fixed reporting "Use the latest vue-eslint-parser" message in non-vue files.

All commits: v7.0.0-beta.0 -> v7.0.0-beta.1

latest releases: v7.11.1, v7.11.0, v7.10.0...
pre-release10 months ago