github voyagermesh/voyager 6.0.0-rc.1

Voyager 6.0.0-rc.1 improved documenation and fixes bugs reported since 6.0.0-rc.0 release. This release requires Kubernetes 1.8.0 or later release. We recommend using this release in a test/qa cluster. For new users, please follow the deployment guide here .

Download Docker images via:

docker pull appscode/voyager:6.0.0-rc.1
docker pull appscode/haproxy:1.7.9-6.0.0-rc.1

Notable Changes

  • Prepare docs for 6.0.0-rc.1 #904
  • Fix service name in chart #903
  • Update links to latest release #901
  • Support --enable-admission-webhook=false #900
  • Support multiple webhooks of same apiversion #899
  • Sync chart to stable charts repo #898
  • Document Prometheus integration #896
  • Improve docs #895
  • Update haproxy exporter #894
  • Document user facing RBAC roles #892
  • Skip generating UpdateStatus method #887
  • Delete internal types #886
  • Use official code generator scripts #885
  • Use HAProxy 1.7.10 #884
  • Move node selector to Ingress spec #883
  • Only check NodePort if provided #880
  • Create user facing aggregate roles #879
  • Use rbac/v1 api #878
  • Use github.com/pkg/errors #877
  • Update docs for supported annotations #871
latest releases: v13.0.0-beta.1, v13.0.0-beta.0, v12.0.0...
pre-release2 years ago