github realm/realm-cocoa v10.7.7

Xcode 12.2 is now the minimum supported version.

Enhancements

  • Add Xcode 13 beta 1 binaries to the release package.

Fixed

  • Fix a runtime crash which happens in some Xcode version (Xcode < 12, reported
    in Xcode 12.5), where SwiftUI is not weak linked by default. This fix only
    works for Cocoapods projects.
    (#7234
  • Fix warnings when building with Xcode 13 beta 1.

Compatibility

  • Realm Studio: 10.0.0 or later.
  • APIs are backwards compatible with all previous releases in the 10.x.y series.
  • Carthage release for Swift is built with Xcode 12.5.
  • CocoaPods: 1.10 or later.
  • Xcode: 12.2-13.0 beta 1.
latest releases: v10.11.0, v10.10.0, v10.9.0...
one month ago