github rabbitmq/cluster-operator v2.0.0
2.0.0

latest releases: v2.9.0, v2.8.0, v2.7.0...
22 months ago

Breaking Changes ⚠️

This version requires RabbitMQ 3.9.9 upwards. Please ensure all existing RabbitMQ clusters are 3.9.9 upwards before upgrading else those RabbitMQ clusters will fail to start after cluster-operator upgrade.
If you cannot upgrade some of your existing RabbitMQ clusters to 3.9.9 or newer, pause reconciliation before upgrading the cluster-operator.

See Pause reconciliation for a RabbitMQ cluster.

Release Notes

  • Merge pull request #1144 from rabbitmq/version-go-in-prom-tests [8f21ba0]
  • Explicitly install a known golang version. [0918e6d]
  • Merge pull request #1140 from ElfoLiNk/patch-1 [7c20c4f]
  • Merge pull request #1143 from rabbitmq/k8s1.25.1 [35f787c]
  • Bump k8s dependencies to 1.25.1 [9ace92d]
  • Fix FileDescriptorsNearLimit [b7732ed]
  • Merge pull request #1139 from rabbitmq/k8s125 [53f23a6]
  • Set github workflow to latest go to resolve vul scan errors [35e8e89]
  • Resolve GO-2022-0969 [f6fb529]
  • Bump k8s api to 1.25 (controller-runtime 0.13) [23e244c]
  • Fixing .yaml to .yml bug on operatorhub pipeline (#1132) [97e2dc5]
  • Merge pull request #1129 from rabbitmq/govulncheck [eb58da6]
  • Bump go to 1.19 in github actions unit/integration tests. [df7738f]
  • Add govulncheck to makefile. [d43cd88]
  • Merge pull request #1130 from rabbitmq/go119 [22f7974]
  • Bump golang to 1.19 [47b2492]
  • operatorhub workflow updated to include Openshift Ecosystem PR (#1118) [3f5a3bb]
  • Merge pull request #1115 from rabbitmq/json-log-example [16ee94f]
  • Remove version restriction on JSON-log example [00555ae]
  • Merge pull request #1113 from rabbitmq/cluster-size-hint [f8d9ac5]
  • Minimal support version is 3.9.9 [7a7f89f]
  • Set cluster.size.hint to replicas count [e08dfe2]
  • Fix spelling mistakes found by goreportcard. (#1112) [e186a81]
  • Test against minimum supported version [b6936b7]
  • Remove deprecated cluster_formation configuration [b81e0f9]
  • Simplify CLI command to enable feature flags [d2d1763]
  • Stop testing rmq 3.8 as it EOL (#1110) [253ba87]
  • Use EntryDescription for DescribeTable tests (#1109) [1bc9c0b]
  • Update crd after k8s api and controller-gen bump (#1107) [8a135dc]
  • Adding a workflow to create a PR to k8s-operatorhub/community-operators (#1103) [7252cd5]
  • Merge pull request #1084 from jiuker/short-if-return [71b52ae]
  • More reliable system tests (#1086) [6a580b8]
  • Merge pull request #1085 from rabbitmq/Zerpet-patch-1 [70821f8]
  • Update CodeQL workflow [bba934c]
  • short if return [8fa4cd1]
  • Merge pull request #1069 from rabbitmq/update-copyright [7e540ed]
  • Update copyright dates. [84d99eb]

Dependency Changes

  • Bump github.com/cloudflare/cfssl from 1.6.1 to 1.6.2 [5305892]
  • Bump github.com/mikefarah/yq/v4 from 4.25.2 to 4.25.3 [434e3f8]
  • Bump github.com/mikefarah/yq/v4 from 4.25.3 to 4.26.1 [a70be40]
  • Bump github.com/mikefarah/yq/v4 from 4.26.1 to 4.27.2 [d910a88]
  • Bump github.com/mikefarah/yq/v4 from 4.27.2 to 4.27.3 [8c4cf21]
  • Bump github.com/mikefarah/yq/v4 from 4.27.3 to 4.27.5 [fa4075a]
  • Bump github.com/onsi/ginkgo/v2 from 2.1.4 to 2.1.6 [e9232a3]
  • Bump github.com/onsi/ginkgo/v2 from 2.1.6 to 2.2.0 [b7401cb]
  • Bump github.com/onsi/gomega from 1.19.0 to 1.20.0 [bf8a27f]
  • Bump github.com/onsi/gomega from 1.20.0 to 1.20.1 [8a346dc]
  • Bump github.com/onsi/gomega from 1.20.1 to 1.20.2 [6a89c7c]
  • Bump gopkg.in/ini.v1 from 1.66.6 to 1.67.0 (#1108) [a71c261]
  • Bump k8s.io/apimachinery from 0.24.0 to 0.24.2 [c871819]
  • Bump k8s.io/apimachinery from 0.24.2 to 0.24.3 [944daba]
  • Bump k8s.io/apimachinery from 0.24.3 to 0.24.4 [fde6d49]
  • Bump k8s.io/klog/v2 from 2.60.1 to 2.70.0 [716fb57]
  • Bump k8s.io/klog/v2 from 2.70.0 to 2.70.1 [a049c3f]
  • Bump k8s.io/klog/v2 from 2.70.1 to 2.80.0 [a9ce835]
  • Bump k8s.io/klog/v2 from 2.80.0 to 2.80.1 [92f2df4]
  • Bump sigs.k8s.io/controller-runtime from 0.12.1 to 0.12.2 [80a0d46]
  • Bump sigs.k8s.io/controller-runtime from 0.12.2 to 0.12.3 [792339a]
  • Bump sigs.k8s.io/controller-tools from 0.9.0 to 0.9.2 [fc04567]
  • Bump sigs.k8s.io/kind from 0.14.0 to 0.15.0 [6f60ebb]
  • Bump sigs.k8s.io/kustomize/kustomize/v4 from 4.5.5 to 4.5.6 [f1c4f13]
  • Bump sigs.k8s.io/kustomize/kustomize/v4 from 4.5.6 to 4.5.7 [a717936]
  • Exclude dependabot from auto-generated release notes (#1116) [1525969]

Don't miss a new cluster-operator release

NewReleases is sending notifications on new releases.