github openebs/openebs v3.8.0

latest releases: v3.10.0, v3.9.0
7 months ago

Release Summary

🎉 🎉 🎉 OpenEBS 3.8 introduces new Mayastor features, and bug fixes. All CSI LocalPV engines, cStor and Jiva now support Kuberenetes v1.27.


Upgrade and Backward Incompatibilities

Please review this list prior to deciding to upgrade:

  • Kubernetes 1.21 or higher release is recommended as this release uses features of Kubernetes that will not be compatible with older Kubernetes releases. Kubernetes 1.19.12 or higher is recommended for using Rawfile Local PV.

Component versions

OpenEBS is a collection of data engines and operators to create different types of replicated and local persistent volumes for Kubernetes Stateful workloads. Kubernetes volumes can be provisioned via CSI Drivers or using Out-of-tree Provisioners. The status of the various components as of v3.8.0 are as follows:

Change Summary

A detailed changelog is available under the component repositories listed above. Here is a quick summary of what has changed since the last release.

  • Mayastor changes: https://github.com/openebs/mayastor/releases/tag/v2.3.0
  • cStor: Prevent volume from scheduling to offline or readonly Pool
  • ZFSLocalPV: Allow configuration for a wider range of ZFS compression options
  • cStor, Jiva, ZFSLocalPV, LVMLocalPV, Device-LocalPV: Upgrade CSI Sidecars for Kubernetes 1.27 support

Show your Support

Are you using or evaluating OpenEBS? You can help OpenEBS in its journey towards becoming a CNCF Incubation project by sharing your OpenEBS story and join the league of OpenEBS Adopters.

Shoutouts!

MANY THANKS to our existing contributors and for everyone helping OpenEBS Community going. @Abhinandan-Purkait @avishnu @blaisedias @chriswldenyer @mtzaurus @niladrih @tiagolobocastro @w3aman @abhilashshetty04 @rohan2794 @dsavitskiy @sinhaashish @datacore-vvarakantham @dsharma-dc @hrudaya21 @pchandra19 @milanhajek @vharsh

A very special thanks to our first-time contributors to code, tests, and docs: @AJDatacore @jnels124 @aceat64 @cxfcxf

Documentation

https://openebs.io/docs

Install

OpenEBS can be installed via kubectl or helm. Follow the installation instructions here.

Upgrade

The upgrade instructions for various OpenEBS engines are here.

Do not upgrade if you are using legacy cstor or jiva provisioners. You have to first migrate those to the corresponding CSI Drivers. Please reach out to us for support

Known Issues

Check our open issues uncovered through e2e and community testing.

Check out the Mayastor release notes for known Mayastor issues.

Support

If you are having issues in setting up or upgrade, you can contact:

Don't miss a new openebs release

NewReleases is sending notifications on new releases.