This release contains a bunch of minor but breaking changes 💥
Props Renamed
Some props and functions names got changed to better communicate their purpose and avoid any obscure terminology
lazy
prop onuseQuery
andQuery
has been renamed tofetchOnMount
to better communicate the purpose- Changed the
pausing
terminology foruseQuery
andQuery
to better reflect their use,resume
is nowwatchVariables
andpause
is nowunwatchVariables
,isPaused
is nowisWatchingVariables
. A little verbose but clear cut - renamed
pause
prop name to bepaused
on bothQuery
andSubscription
components - renamed
suspend
prop onQuery
component tosuspended
for consistency with other props
Subscription Changes
- subscriptions have been re-implemented as a simple plugin
handleSubscriptions
rather than their own weird thing, which allows subscriptions to participate in the plugins pipeline (previously they didn't)