renamed repo from go-validate-yourself to validator for better go package and library naming ( more idiomatic )
updated function name to be more go idiomatic for example instead of ValidateStruct it's just Struct
example: validate := validator.New("validate", validator.BakedInFunctions)
validate.Struct(struct)
validate.Field(field, tag)
validate.FieldWithValue(field, value, tag)
I hope this change isn't too disruptive, but believe these changes were needed for a truly production and community ready library.