github firebase/firebase-admin-node v9.9.0
Firebase Admin Node.js SDK v9.9.0

Breaking Changes

  • change: The Admin SDK now requires Node.js 10.13.0 or higher. (#1300)

New Features

  • feat(auth): Added code flow support for OIDC flow. (#1220)

Bug Fixes

  • fix(auth): make MFA uid optional for updateUser operations (#1278)
  • fix: Revert regression introduced in #1257 (#1277)

Miscellaneous

  • [chore] Release 9.9.0 (#1302)
  • Fixed integration test failure of skipped tests (#1299)
  • chore: Teporarily disabling sendToDeviceGroup integration test (#1292)
  • build(deps-dev): bump @microsoft/api-extractor from 7.11.2 to 7.15.2 (#1291)
  • build(deps-dev): bump chalk from 1.1.3 to 4.1.1 (#1288)
  • build(deps-dev): bump nyc from 14.1.1 to 15.1.0 (#1290)
  • build(deps-dev): bump sinon from 9.0.2 to 9.2.4 (#1289)
  • build(deps-dev): bump run-sequence from 1.2.2 to 2.2.1 (#1282)
  • build(deps-dev): bump gulp-header from 1.8.12 to 2.0.9 (#1283)
  • chore: Remove gulp-replace dependency (#1285)
  • chore: Enabled dependabot (#1279)
  • build(deps): bump jose from 2.0.4 to 2.0.5 (#1265)
  • build(deps): bump handlebars from 4.7.6 to 4.7.7 (#1253)
20 days ago