github eclipse/jetty.project jetty-9.4.45.v20220203
9.4.45.v20220203

3 months ago

Special Thanks to the following Eclipse Jetty community members

Changelog

  • #7516 - Fix log class name in ArrayByteBufferPool (@slovdahl)
  • #7496 - Transient 400: Bad Request responses in jetty-9.4.45.v20220128
  • #7480 - remove duplicated dependencies and upgrade to last spring 3.2.x
  • #7440 - ContextHandler.getAliasChecks() breaks Spring Boot
  • #7375 - Some environments require Request scoping during session save
  • #7348 - Slow CONNECT request causes NPE
  • #7277 - Allow override of ServletRequest.getLocalName() and .getLocalPort() in post-intermediary scenarios
  • #7271 - It is necessary to set MAX_CAPACITY to ArrayTernaryTrie/ArrayTrie
  • #7266 - Wrong ALPN jars are selected for newer versions of JDK8
  • #7222 - Remove redundant overridden methods in AllowedResourceAliasCheckListener
  • #7124 - Add default methods on LifeCycle.Listener interface
  • #7078 - CompressionPools are not shared between multiple contexts for 9.4 WebSocket
  • #7059 - NPE in AllowedResourceAliasChecker.getPath()
  • #7031 - ResponseWriter.println(char) does not print newline
  • #6974 - Major websocket memory change in 9.4.36
  • #6969 - Getting 404 failures when trying to enable logging-log4j module.
  • #6965 - Expose Spec ServerContainer.upgrade() API
  • #6889 - Cherry pick update to infinispan 11.0.11 back to jetty-9.4.x(#6766)
  • #6497 - Replace SameFileAliasChecker
  • #4275 - Path Normalization/Traversal - Context Matching

Dependencies

  • #7519 - Bump google-cloud-datastore from 2.2.2 to 2.2.3
  • #7501 - Bump checkstyle from 9.2.1 to 9.3
  • #7500 - Bump asciidoctor-maven-plugin from 2.2.1 to 2.2.2
  • #7456 - Bump grpc-core from 1.43.2 to 1.44.0
  • #7449 - Bump error_prone_annotations from 2.10.0 to 2.11.0
  • #7445 - Bump guice from 5.0.1 to 5.1.0
  • #7439 - Bump versions-maven-plugin from 2.8.1 to 2.9.0
  • #7435 - Investigate Infinispan transitive dependencies
  • #7434 - Fix log4j2 module
  • #7429 - Bump mariadb-java-client from 2.7.4 to 2.7.5
  • #7427 - Bump testcontainers.version from 1.16.2 to 1.16.3
  • #7412 - Bump maven-plugin-plugin from 3.6.2 to 3.6.4
  • #7411 - Bump maven.plugin-tools.version from 3.6.2 to 3.6.4
  • #7389 - Bump google-cloud-datastore from 2.2.1 to 2.2.2
  • #7388 - Bump maven-compiler-plugin from 3.8.1 to 3.9.0
  • #7387 - Bump build-helper-maven-plugin from 3.2.0 to 3.3.0
  • #7386 - Bump jboss-logging from 3.4.2.Final to 3.4.3.Final
  • #7380 - Bump hawtio-default from 2.14.3 to 2.14.4
  • #7368 - Bump jnr-posix from 3.1.14 to 3.1.15
  • #7366 - Bump jnr-unixsocket from 0.38.15 to 0.38.17
  • #7364 - Bump jnr-enxio from 0.32.12 to 0.32.13
  • #7363 - Bump grpc-core from 1.43.1 to 1.43.2
  • #7359 - Bump spotbugs-maven-plugin from 4.5.2.0 to 4.5.3.0
  • #7346 - Bump maven-deploy-plugin from 3.0.0-M1 to 3.0.0-M2
  • #7342 - Bump checkstyle from 9.2 to 9.2.1
  • #7341 - Bump maven-site-plugin from 3.9.1 to 3.10.0
  • #7338 - Bump jmh.version from 1.33 to 1.34
  • #7336 - Bump logback.version from 1.2.9 to 1.2.10
  • #7332 - Bump plexus-container-default from 2.1.0 to 2.1.1
  • #7331 - Bump plexus-component-annotations from 2.1.0 to 2.1.1
  • #7329 - Bump maven.resolver.version from 1.7.2 to 1.7.3
  • #7324 - Bump spotbugs-maven-plugin from 4.5.0.0 to 4.5.2.0
  • #7321 - Bump grpc-core from 1.43.0 to 1.43.1
  • #7312 - Bump hawtio-default from 2.14.2 to 2.14.3
  • #7308 - Bump openwebbeans.version from 2.0.24 to 2.0.25
  • #7301 - Bump logback.version from 1.2.8 to 1.2.9
  • #7290 - Bump grpc-core from 1.42.1 to 1.43.0
  • #7287 - Bump logback.version from 1.2.7 to 1.2.8
  • #7264 - Bump hawtio-default from 2.14.1 to 2.14.2
  • #7258 - Upgrade log4j2 from 2.14.0 to 2.15.0
  • #7253 - Upgrade jackson-databind to 2.13.0
  • #7246 - Bump openwebbeans.version from 2.0.23 to 2.0.24
  • #7238 - Bump jnr-posix from 3.1.13 to 3.1.14
  • #7237 - Bump jnr-unixsocket from 0.38.14 to 0.38.15
  • #7235 - Bump org.eclipse.osgi from 3.17.0 to 3.17.100
  • #7216 - Bump google-cloud-datastore from 2.2.0 to 2.2.1
  • #7213 - Bump buildnumber-maven-plugin from 1.4 to 3.0.0
  • #7205 - Bump jnr-posix from 3.1.12 to 3.1.13
  • #7202 - Bump jnr-unixsocket from 0.38.13 to 0.38.14
  • #7199 - Bump jnr-ffi from 2.2.9 to 2.2.10
  • #7198 - Bump jnr-enxio from 0.32.11 to 0.32.12
  • #7177 - Bump maven.plugin-tools.version from 3.6.1 to 3.6.2
  • #7175 - Bump checkstyle from 9.1 to 9.2
  • #7173 - Bump junit.version from 5.8.1 to 5.8.2
  • #7156 - Bump jnr-unixsocket from 0.38.12 to 0.38.13
  • #7155 - Bump jnr-ffi from 2.2.8 to 2.2.9
  • #7150 - Bump jnr-posix from 3.1.11 to 3.1.12
  • #7149 - Bump jnr-enxio from 0.32.10 to 0.32.11
  • #7145 - Bump maven.version from 3.8.3 to 3.8.4
  • #7136 - Bump spotbugs-maven-plugin from 4.4.2.2 to 4.5.0.0
  • #7129 - Bump google-cloud-datastore from 2.1.3 to 2.2.0
  • #7115 - Bump grpc-core from 1.42.0 to 1.42.1
  • #7105 - Bump logback.version from 1.2.6 to 1.2.7
  • #7090 - Bump jna from 5.9.0 to 5.10.0
  • #7085 - Bump grpc-core from 1.41.0 to 1.42.0
  • #7083 - Bump error_prone_annotations from 2.9.0 to 2.10.0
  • #7070 - Bump checkstyle from 9.0.1 to 9.1
  • #7069 - Bump gson from 2.8.8 to 2.8.9
  • #7046 - Bump h2spec-maven-plugin from 1.0.8 to 1.0.9
  • #7039 - Bump testcontainers.version from 1.16.1 to 1.16.2
  • #7038 - Bump hawtio-default from 2.14.0 to 2.14.1
  • #7036 - Bump awaitility from 4.1.0 to 4.1.1
  • #7030 - Bump h2spec-maven-plugin from 1.0.7 to 1.0.8
  • #7027 - Bump spotbugs-maven-plugin from 4.4.2.1 to 4.4.2.2
  • #7023 - Bump google-cloud-datastore from 2.1.2 to 2.1.3
  • #7020 - Bump testcontainers.version from 1.16.0 to 1.16.1
  • #7015 - Bump ant.version from 1.10.11 to 1.10.12
  • #7005 - Bump spotbugs-maven-plugin from 4.4.2 to 4.4.2.1
  • #6994 - Bump spotbugs-maven-plugin from 4.4.1 to 4.4.2
  • #6992 - Bump osgi.annotation from 8.0.0 to 8.0.1
  • #6975 - Bump jboss-threads from 3.1.0.Final to 3.4.2.Final
  • #6972 - Bump jboss-logmanager from 2.1.15.Final to 2.1.18.Final
  • #6957 - Bump checkstyle from 9.0 to 9.0.1
  • #6956 - Bump maven.version from 3.8.2 to 3.8.3
  • #6936 - Bump guava from 30.1.1-jre to 31.0.1-jre

Don't miss a new jetty.project release

NewReleases is sending notifications on new releases.