github eclipse/jetty.project jetty-11.0.8
11.0.8

3 months ago

Special Thanks to the following Eclipse Jetty community members

Changelog

  • #7524 - Missing package in JmxConfiguration
  • #7523 - Typo in AnnotationConfiguration
  • #7514 - Adding InheritedListeners to already-started components can cause IllegalStateException
  • #7430 - Run WebSocket Autobahn test for all Jetty, Javax and Core APIs
  • #7419 - Update resource base example so it works (@Artur-)
  • #7417 - Clarify that requestHeaderSize is a cumulative limit (@mszabo-wikia)
  • #7375 - Some environments require Request scoping during session save
  • #7369 - Document CustomRequestLog
  • #7361 - Fix resource leaks in PropertyUserStore, XmlConfiguraiton, and start.jar (@lujiefsi)
  • #7351 - Large WebSocket payloads with permessage-deflate hang on 10.0.7
  • #7348 - Slow CONNECT request causes NPE
  • #7327 - jetty-slf4j-impl missing from BOM
  • #7313 - addBean(_attributes); only called in the Convenience constructor of org.eclipse.jetty.server.Server
  • #7299 - Enabling the logging-logback module prevents eclipse remote debugging
  • #7297 - Deprecate log4j 1.x support
  • #7294 - Fix possible NPE from WebSocketAdapter
  • #7277 - Allow override of ServletRequest.getLocalName() and .getLocalPort() in post-intermediary scenarios
  • #7262 - Allow the SerlvetHandler.getFilterChain method to be overridden.
  • #7240 - Clarify and javadoc InvocationType
  • #7160 - HttpURI considers %25 to be ambiguous, preventing access to static resources with % in their name
  • #7132 - Tidy up demo webapps
  • #7131 - Use Charset instead of encoding string where possible
  • #7124 - Add default methods on LifeCycle.Listener interface
  • #7111 - Add support to deprecate jetty-home modules
  • #7109 - Deprecate UnixSocket JNR support
  • #7103 - Rework LaF of distro landing page
  • #7086 - WebSocket: java.lang.IllegalStateException: already released RetainableByteBuffer
  • #7064 - Cleanup or clarify (null) in output of --list-config
  • #7063 - Simplify command line use of org.eclipse.jetty.util.Password
  • #7062 - test-keystore.p12 is no longer packaged in jetty-home
  • #7059 - NPE in AllowedResourceAliasChecker.getPath()
  • #7042 - Simplify configuration to use different OpenIdConfiguration per webapp.
  • #7031 - ResponseWriter.println(char) does not print newline
  • #7008 - Problem with jetty.sh start regression 10.0.6 -> 10.0.7 when using JETTY_USER
  • #6987 - jetty-unixdomain-server is missing from jetty-bom (@markslater)
  • #6985 - ELContextCleaner references javax class in jetty-11
  • #6980 - ELContextCleaner failed because cannot access a member of class javax.el.BeanELResolver with modifiers "private static final"
  • #6973 - Jetty starts consuming CPU that remains high even without any traffic
  • #6965 - Expose Spec ServerContainer.upgrade() API
  • #6497 - Replace SameFileAliasChecker
  • #6282 - SecuredRedirectHandler should probably redirect with 301 (@dellgreen)
  • #6017 - Property overriding does not work
  • #4317 - EventSource does not work with GzipHandler
  • #4275 - Path Normalization/Traversal - Context Matching
  • #2690 - Clarify ordering, concurrency behavior of WebSocketListener and normal HTTP responses
  • #2504 - Expose more WebSocket details in JMX and Server Dump
  • #1087 - Support .well-known serving in handlers
  • #100 - Can't deploy web app as an unpacked directory inside a bundle JAR on Felix

Dependencies

  • #7529 - Upgrade quiche to version 0.11.0
  • #7520 - Bump google-cloud-datastore from 2.2.2 to 2.2.3
  • #7508 - Bump logback-core from 1.3.0-alpha12 to 1.3.0-alpha13
  • #7502 - Bump checkstyle from 9.2.1 to 9.3
  • #7499 - Bump asciidoctor-maven-plugin from 2.2.1 to 2.2.2
  • #7495 - remove unsupported modules
  • #7491 - Bump jakarta.inject-api from 2.0.0 to 2.0.1
  • #7487 - Bump jsp.impl.version from 10.0.10 to 10.0.14
  • #7470 - Bump error_prone_annotations from 2.10.0 to 2.11.0
  • #7462 - Bump grpc-core from 1.43.2 to 1.44.0
  • #7447 - Bump guice from 5.0.1 to 5.1.0
  • #7438 - Bump versions-maven-plugin from 2.8.1 to 2.9.0
  • #7435 - Investigate Infinispan transitive dependencies
  • #7433 - Bump tycho-p2-repository-plugin from 2.5.0 to 2.6.0
  • #7428 - Bump mariadb-java-client from 2.7.4 to 2.7.5
  • #7426 - Bump testcontainers-bom from 1.16.2 to 1.16.3
  • #7416 - Bump maven-plugin-plugin from 3.6.2 to 3.6.4
  • #7410 - Bump maven.plugin-tools.version from 3.6.2 to 3.6.4
  • #7402 - Bump jnr-unixsocket from 0.38.15 to 0.38.17
  • #7401 - Bump grpc-core from 1.43.1 to 1.43.2
  • #7399 - Bump maven-bundle-plugin from 5.1.3 to 5.1.4
  • #7397 - Bump hawtio-default from 2.14.3 to 2.14.4
  • #7385 - Bump build-helper-maven-plugin from 3.2.0 to 3.3.0
  • #7384 - Bump asciidoctorj from 2.5.2 to 2.5.3
  • #7383 - Bump maven-jar-plugin from 3.2.0 to 3.2.2
  • #7381 - Bump jboss-logging from 3.4.2.Final to 3.4.3.Final
  • #7379 - Bump google-cloud-datastore from 2.2.1 to 2.2.2
  • #7367 - Bump jnr-posix from 3.1.14 to 3.1.15
  • #7365 - Bump jnr-ffi from 2.2.10 to 2.2.11
  • #7362 - Bump jnr-enxio from 0.32.12 to 0.32.13
  • #7358 - Bump spotbugs-maven-plugin from 4.5.2.0 to 4.5.3.0
  • #7347 - Bump maven-scm-provider-jgit from 1.10.0 to 1.12.2
  • #7345 - Bump maven-deploy-plugin from 3.0.0-M1 to 3.0.0-M2
  • #7343 - Bump log4j-api from 2.17.0 to 2.17.1
  • #7340 - Bump checkstyle from 9.2 to 9.2.1
  • #7339 - Bump maven-site-plugin from 3.9.1 to 3.10.0
  • #7337 - Bump jmh.version from 1.33 to 1.34
  • #7334 - Bump logback-core from 1.3.0-alpha11 to 1.3.0-alpha12
  • #7333 - Bump plexus-component-annotations from 2.1.0 to 2.1.1
  • #7330 - Bump maven.resolver.version from 1.7.2 to 1.7.3
  • #7325 - Bump spotbugs-maven-plugin from 4.5.0.0 to 4.5.2.0
  • #7323 - Bump grpc-core from 1.43.0 to 1.43.1
  • #7322 - Bump hazelcast.version from 4.2.3 to 4.2.4
  • #7310 - Bump log4j-api from 2.16.0 to 2.17.0
  • #7309 - Bump hawtio-default from 2.14.2 to 2.14.3
  • #7306 - Bump openwebbeans.version from 2.0.24 to 2.0.25
  • #7303 - Bump log4j-api from 2.16.0 to 2.17.0
  • #7300 - Bump logback-core from 1.3.0-alpha10 to 1.3.0-alpha11
  • #7289 - Bump hazelcast.version from 4.2.2 to 4.2.3
  • #7288 - Bump grpc-core from 1.42.1 to 1.43.0
  • #7275 - Bump maven-bundle-plugin from 5.1.2 to 5.1.3
  • #7274 - Bump log4j-api from 2.15.0 to 2.16.0
  • #7265 - Bump hawtio-default from 2.14.1 to 2.14.2
  • #7256 - Bump log4j-api from 2.14.1 to 2.15.0
  • #7254 - Upgrade jackson-databind to 2.13.0
  • #7245 - Bump openwebbeans.version from 2.0.23 to 2.0.24
  • #7239 - Bump org.eclipse.osgi from 3.17.0 to 3.17.100
  • #7236 - Bump jnr-posix from 3.1.13 to 3.1.14
  • #7234 - Bump jnr-unixsocket from 0.38.14 to 0.38.15
  • #7233 - Bump httpcore from 4.4.14 to 4.4.15
  • #7224 - Bump org.apache.felix.framework from 7.0.1 to 7.0.3
  • #7214 - Bump google-cloud-datastore from 2.2.0 to 2.2.1
  • #7204 - Bump jnr-enxio from 0.32.11 to 0.32.12
  • #7196 - Bump jnr-posix from 3.1.12 to 3.1.13
  • #7194 - Bump jnr-unixsocket from 0.38.13 to 0.38.14
  • #7191 - Bump jnr-ffi from 2.2.9 to 2.2.10
  • #7179 - Bump checkstyle from 9.1 to 9.2
  • #7176 - Bump maven-plugin-plugin from 3.6.1 to 3.6.2
  • #7174 - Bump junit.version from 5.8.1 to 5.8.2
  • #7172 - Bump maven.plugin-tools.version from 3.6.1 to 3.6.2
  • #7154 - Bump jnr-unixsocket from 0.38.12 to 0.38.13
  • #7152 - Bump jnr-enxio from 0.32.10 to 0.32.11
  • #7151 - Bump jnr-posix from 3.1.11 to 3.1.12
  • #7144 - Bump maven.version from 3.8.3 to 3.8.4
  • #7135 - Bump spotbugs-maven-plugin from 4.4.2.2 to 4.5.0.0
  • #7128 - Bump google-cloud-datastore from 2.1.3 to 2.2.0
  • #7116 - Bump grpc-core from 1.42.0 to 1.42.1
  • #7089 - Bump jna from 5.9.0 to 5.10.0
  • #7084 - Bump error_prone_annotations from 2.9.0 to 2.10.0
  • #7082 - Bump grpc-core from 1.41.0 to 1.42.0
  • #7068 - Bump gson from 2.8.8 to 2.8.9
  • #7067 - Bump checkstyle from 9.0.1 to 9.1
  • #7045 - Bump h2spec-maven-plugin from 1.0.8 to 1.0.9
  • #7040 - Bump hawtio-default from 2.14.0 to 2.14.1
  • #7037 - Bump testcontainers-bom from 1.16.1 to 1.16.2
  • #7035 - Bump awaitility from 4.1.0 to 4.1.1
  • #7029 - Bump spotbugs-maven-plugin from 4.4.2.1 to 4.4.2.2
  • #7028 - Bump h2spec-maven-plugin from 1.0.7 to 1.0.8
  • #7024 - Bump google-cloud-datastore from 2.1.2 to 2.1.3
  • #7019 - Bump testcontainers-bom from 1.16.0 to 1.16.1
  • #7014 - Bump ant.version from 1.10.11 to 1.10.12
  • #7012 - Remove all old geronimo spec jars from jetty-10
  • #7007 - Bump spotbugs-maven-plugin from 4.4.2 to 4.4.2.1
  • #7006 - Bump jakarta.inject-api from 1.0.3 to 1.0.4
  • #6996 - Bump spotbugs-maven-plugin from 4.4.1 to 4.4.2
  • #6995 - Bump osgi.annotation from 8.0.0 to 8.0.1
  • #6954 - Bump maven.version from 3.8.2 to 3.8.3

Don't miss a new jetty.project release

NewReleases is sending notifications on new releases.