Features & Bug fixes
- Persist payment failure error
- Support custom payment metadata
- Add register webhook to the cli
- Add extra TLVs to send spontaneous payment
- Add payment expiry for pending payments
Breaking changes
- Rename
sweep
toredeem_onchain_funds
What's Changed
- change: lud-16 assersions to ignore cases by @rustaceanrob in #681
- Persist payment failure error by @dangeross in #673
- Add extra TLVs to send spontaneous payment by @dangeross in #679
- set group_id in send_pay by @JssDWt in #685
- enhancement: sort fiat currencies in API by name, add docs by @rustaceanrob in #686
- Fix sdk-flutter Kotlin bindings source by @erdemyerebasmaz in #688
- rename sweep to redeem_onchain_funds by @ubbabeck in #684
- Bump zerocopy from 0.7.29 to 0.7.31 in /libs by @dependabot in #690
- Update flutter rust bridge to latest by @erdemyerebasmaz in #693
- Bumping lightning and lightning-invoice versions by @hydra-yse in #692
- Make code more idiomatic and simple by @andrei-21 in #687
- Python package fix for v0.2.12 by @dangeross in #697
- v0.2.12 by @dangeross in #698
- Bump gl-client by @ok300 in #694
- Downcase domain in lightning address and return normalized address by @andrei-21 in #695
- Payment expiry for pending payments by @ubbabeck in #674
- only iterate over pending payments for update_payment_expirations by @ubbabeck in #707
- Improve sync payments by @dangeross in #709
- Use a non-zero timeout in our HTTP clients by @ok300 in #718
- Allow custom payment metadata inside SDK storage by @hydra-yse in #706
- Rerun codegen by @dangeross in #721
- Add register webhook to the cli by @roeierez in #720
- Document ReceivePaymentResponse fields by @ok300 in #719
- document fields of SwapInfo by @ubbabeck in #712
- RN iOS emitter fix by @dangeross in #722
- Add payment and backup exceptions by @ademar111190 in #723
- Fix parsing LUD-17 by replacing
lnurl*
prefix once by @andrei-21 in #731 - Add payment metadata functionality to sdk-cli by @hydra-yse in #732
- Use Android bindings via Gradle in Flutter package by @cnixbtc in #717
- Bump h2 from 0.3.22 to 0.3.24 in /libs by @dependabot in #733
- make short_channel_id optional by @JssDWt in #736
New Contributors
- @hydra-yse made their first contribution in #692
Full Changelog: 0.2.12...0.2.14