github PolymeshAssociation/polymesh-sdk v1.0.0-alpha.19

latest releases: v26.1.0, v26.1.0-beta.1, v26.1.0-alpha.1...
pre-release4 years ago

1.0.0-alpha.19 (2020-09-29)

chore

  • msdk-313 refactor transfers namespace (ad26622)
  • msdk-313 refactor transfers namespace (ec725b1)
  • rename checkTransfer to checkSettle (ecf8ef9)

Features

  • adapt canTransfer to portfolio logic. MSDK-292 (4a2e3b2)
  • add dti to asset identifier enum. MSDK-287 (fb3bd93)
  • add support for country codes in jurisdiction (29577bc)
  • introduce Scope type (d90b9e1)
  • refacor on issueTokens procedure. Task involved: MSDK-261 (eae437b)
  • remove BatchIssue constant (af5cad3)
  • rename master key and signing key. MSDK-294 (1f7196c)
  • rename treasuryIdentity to primaryIssuanceAgent. MSDK-289 (8d19fdb)
  • upgrade to tooling. Involved tasks: MSDK-284 & MSDK-286 (5b77649)

BREAKING CHANGES

    • Transfers namespace changes to Settlements
  • canTransfer renamed to canSettle
  • areFrozen renamed to isFrozen
  • transfers.freeze(), transfers.unfreeze() and transfers.isFrozen() moved to securityToken.freeze(), securityToken.unfreeze() and securityToken.isFrozen()
  • checkTransfer() renamed to checkSettle()
    • SigningKey interface renamed to SecondaryKey:
  • getSigningKeys() and removeSigningKeys() in CurrentIdentity renamed to getSecondaryKeys() and removeSecondaryKeys()
  • api.registerIdentity() arguments changed from { targetAccount: string | Account; expiry?: Date; signingKeys?: SigningKey[] } to { targetAccount: string | Account; secondaryKeys?: SecondaryKey[] }
  • getMasterKey() in Identity renamed to getPrimaryKey
  • AttestMasterKeyRotation and RotateMasterKey in the AuthorizationType enum renamed to AttestPrimaryKeyRotation and RotatePrimaryKey respectively
  • Rule interface renamed to Requirement
  • RuleCompliance interface renamed to RequirementCompliance (rules key changed to requirements)
  • rules namespace in securityToken.compliance renamed to requirements
  • requirements.set() arguments changed from { rules: Condition[][] } to { requirements: Condition[][] }
  • checkMint() removed from securityToken.compliance.requirements
  • canMint() and transfer() removed from securityToken.transfers
  • treasuryIdentity in SecurityTokenDetails renamed to primaryIssuanceAgent
  • api.governance namespace deleted, and all governance/proposal related classes/functionality disabled
  • securityToken.issuance.issue() arguments changed from { issuanceData: IssuanceData } to { amount: BigNumber }
  • tickerReservation.createSecurityToken() arguments no longer accept a treasury parameter. The treasury DID is now always the issuer by default
  • Jurisdiction claim interface changed to { type: ClaimType.Jurisdiction; code: CountryCode; scope: Scope }
  • Transfers namespace changes to Settlements
  • canTransfer renamed to canSettle
  • areFrozen renamed to isFrozen
  • transfers.freeze(), transfers.unfreeze() and transfers.isFrozen() moved to securityToken.freeze(), securityToken.unfreeze() and securityToken.isFrozen()
    • SigningKey interface renamed to SecondaryKey:
  • getSigningKeys() and removeSigningKeys() in CurrentIdentity renamed to getSecondaryKeys() and removeSecondaryKeys()
  • api.registerIdentity() arguments changed from { targetAccount: string | Account; expiry?: Date; signingKeys?: SigningKey[] } to { targetAccount: string | Account; secondaryKeys?: SecondaryKey[] }
  • getMasterKey() in Identity renamed to getPrimaryKey
  • AttestMasterKeyRotation and RotateMasterKey in the AuthorizationType enum renamed to AttestPrimaryKeyRotation and RotatePrimaryKey respectively
  • Rule interface renamed to Requirement
  • RuleCompliance interface renamed to RequirementCompliance (rules key changed to requirements)
  • rules namespace in securityToken.compliance renamed to requirements
  • requirements.set() arguments changed from { rules: Condition[][] } to { requirements: Condition[][] }
  • checkMint() removed from securityToken.compliance.requirements
  • canMint() and transfer() removed from securityToken.transfers
  • treasuryIdentity in SecurityTokenDetails renamed to primaryIssuanceAgent
  • api.governance namespace deleted, and all governance/proposal related classes/functionality disabled
  • securityToken.issuance.issue() arguments changed from { issuanceData: IssuanceData } to { amount: BigNumber }
  • tickerReservation.createSecurityToken() arguments no longer accept a treasury parameter. The treasury DID is now always the issuer by default
  • Jurisdiction claim interface changed to { type: ClaimType.Jurisdiction; code: CountryCode; scope: Scope }
  • ClaimScope.scope changed from string | null to Scope | null and Claim.scope changed from string to Scope This affects multiple endpoints in api.claims:
    • addClaims(), editClaims() and revokeClaims() have Claim as part of their input
    • geetIssuedClaims(), getIdentitiesWithClaims(), getCddClaims() and getTargetingClaims() have Claim as part of their return value
    • getClaimScopes() has ClaimScope[] as its return value

Don't miss a new polymesh-sdk release

NewReleases is sending notifications on new releases.