- Security: the
litellmextra excludes litellm 1.107.0, which upstream
reported compromised
(security incident, 2026-10-21),
and 1.106.0 to 1.106.2, which import the optionalmcppackage on ordinary
tool calls. The extra also requires a patchedfilelock(4.2.1 or later). anthropic2.x is inside the supported range (>=1.0,<3). Before this, the
latest SDK passed content through with anunsupported_versionwarning.
Verify this release
- Registry provenance (trusted publishing from this workflow): https://pypi.org/project/caveman-middleware/1.0.1/#files
- CycloneDX SBOM of the published dependency graph: attached
.cdx.json - Built from annotated, GitHub-verified tag
middleware-python-v1.0.1onmain