github IBM/aspera-cli v4.27.4
Aspera CLI v4.27.4

4 hours ago

New Features

  • orchestrator: Add JWT-based bearer token authentication (default) and API key support via options --auth_style (token, basic, query) and --apikey.
  • aoc: short_link list supports --query=help, help of short_link create|modify shows the request body.
  • node: emulator executes transfers with transferd, and supports more of the Node API. See the manual.
  • general: Linux portable package aspera-cli-<version>-linux-x86_64-glibc<version>-portable.tgz: Ruby, gems and Transfer SDK, extract and run, like the Windows portable package.
  • shares: admin share user_permissions|group_permissions support create, modify and delete (identified by user or group id, e.g. %username:john@example.com).
  • config: commands accepts aliases in the command path (e.g. config commands server browse).

Issues Fixed

  • preview: Generator options with a numeric value given on command line (e.g. --thumb-vid-fraction=0.3, --blend-pauseframes=2) were failing.
  • aoc: short_link show always failed with not found.
  • faspex5: packages receive with a public link now works with a list of files, and ALL.
  • faspex5: packages send now returns the package information (like aoc).
  • config: commands failed with no such command when the command path included positional arguments (e.g. faspex5 packages receive ALL): arguments are now skipped, and an unknown command shows the list of sub-commands.
  • aoc: files short_link public modify with access_levels set full access (edit) instead of the given levels.
  • aoc: packages shared_inboxes short_link public commands were failing (wrong short link purpose, parameters of shared folder links). Link type private is removed: AoC supports it only for shared folders.
  • general: Agent node was failing when the transfer was canceled or paused on the node.
  • general: When the default CA certificate locations of Ruby's OpenSSL do not exist (e.g. single executable built on another Linux distribution), the system CA bundle is used.
  • general: Windows portable package displayed Ignoring bigdecimal-... because its extensions are not built at each start.
  • general: Fixed #265 #266: Linux single executable of 4.27.3 ran every command as config commands <command>: e.g. config transferd install only displayed its syntax, and faspex5 packages receive ALL failed with no such command.
  • config: transferd install with --sdk-url=file:///...tar.gz (local SDK archive, Linux) failed with not in gzip format.
  • general: Linux single executable: commands could fail with cannot load such file (e.g. config transferd install: rubygems/package): it now includes the whole Ruby standard library and all files of gems.
  • general: Progress bar: stayed at 0% when the total size was not known (the transferred size is now shown), rate was underestimated (it included connection time: now averaged over the last 5 seconds, in decimal Mbps like ascp), a resumed session doubled the total size or failed the transfer, a second HTTP download accumulated the first one, multi-session state was shared between sessions in agent direct. Errors in the progress bar no longer fail the transfer.
  • general: Progress bar: a failed transfer was displayed as completed (the bar now stops at the reached progress, with failed), log lines were mixed with the progress bar (they are now displayed above it), files already at destination (whole or partially, when resumed) were not counted in progress, multi-session progress exceeded the total size (agent direct), agent httpgw did not terminate the progress bar.
  • general: Agent direct: when ascp ended without final status (e.g. killed), ascli failed with wrong number of arguments: the transfer is now resumed.
  • shares: Help of admin share create|modify showed fields path and description, rejected by Shares (error 500): fields are directory and create_directory. Same for description in admin group local create|modify.
  • aoc: admin user preferences|notifications show|modify failed with undefined method 'setup_admin_user_instance'.
  • general: With --bulk=yes, commands under a node with an identifier (e.g. node access_keys do <id> delete, faspex5 admin nodes shared_folders <id> delete, shares admin share user_permissions <id> delete) failed with Missing argument: command: only arguments supporting bulk operations are read as a list.
  • server: Aliases browse, delete and rename executed ls, rm and mv even when ascmd is not available.
  • config: wizard displayed a test command that does not exist for faspio, orchestrator, console and server.
  • faspex5: With a public link to a package, the first argument of packages browse, status and receive was ignored (e.g. the folder of browse, the first file of receive).
  • general: A multi-line value was evaluated as an extended value when any of its lines, not only the first one, started with a decoder (e.g. @ruby:): such a value is now taken as is.
  • general: @stdin:chomp was failing.
  • general: A configuration file with an error to fix (e.g. duplicate keys) was renamed *.manual_conversion_needed, and a new empty configuration file was created on next execution: the file is now left untouched, and the error is displayed.
  • general: --out.level was overridden by --format given after it, or in the same --out value: e.g. --out.level=info --format=json displayed secrets.
  • general: Integers with a leading zero were rejected in options (e.g. --version-check-days=08) and arguments, or read as octal in dotted values (e.g. --query.page=010). An invalid number in an option now gives the name of the option.
  • faspex5: admin shared_inboxes|workgroups saml_groups modify|delete with a percent selector (e.g. %name:my_group) failed with assertion failed.
  • faspex5: Lists were read endlessly if the server returned an empty page before the total count, and failed without total count.
  • config: vault of type file without name failed with no implicit conversion of nil into String (default name: vault.bin).
  • general: Interactive prompts were displayed on stdout, mixed with results (e.g. when redirected to a file): they are now displayed on stderr.
  • general: Security: the encrypted vault file was readable by other users, and files with secrets (configuration, persistency, generated private key) were readable by other users until access was restricted, just after creation: they are now created with restricted access.
  • general: Security: secrets of transfer agent parameters (e.g. password of agent node) were saved in clear with asynchronous transfers: config transfer status now takes them from the current transfer option.

Breaking Changes

  • general: With --format=json, jsonpp, yaml or ruby, the output is always valid in this format: a status is a string (e.g. "complete"), an empty list is [], and no result is null (were displayed as plain text, e.g. complete, empty, nothing).
  • node: emulator requires transferd and the gem grpc, instead of ascp.
  • node: simulator is not renamed and is an alias of emulator.
  • node: emulator parameter browse_root is renamed docroot.
  • general: Release archives are named aspera-cli-<version>-<os>-<cpu>...: single executable aspera-cli-<version>-linux-x86_64-glibc<version>-ocran.tgz (was ascli-...), Windows portable aspera-cli-<version>-windows-x86_64-portable.zip (was windows-amd64).
  • orchestrator: Command plugins is now plugins list.
  • orchestrator: Default authentication is now JWT token.
  • general: The progress bar is displayed on standard error (was standard output), by default if standard error is a terminal: it is displayed even if the output of the command is redirected to a file. Agent direct: if transfer parameter quiet is false (native progress bar of ascp), the progress bar of ascli is not displayed, unless option progress_bar is set.

Server Versions

Plugin Product Version
aoc Aspera on Cloud SaaS
console IBM Aspera Console 3.4.4
faspex5 Faspex v5 F5.0.17
httpgw HTTP Gateway 2.3.4
node HSTS Node API 4.4.8.2596
orchestrator Orchestrator 4.1.6.2036-00000
shares IBM Aspera Shares 1.9.14

Transfer Agent Versions

Agent Product Version
connect IBM Aspera Connect Client 4.2.14
desktop IBM Aspera Desktop Client 4.4.3
direct IBM Aspera Transfer SDK (ascp) 1.1.9
httpgw IBM Aspera HTTP Gateway Agent 1.3.0
node IBM Aspera Node API Agent 4.4.3
transferd IBM Aspera transferd daemon 1.1.9

Don't miss a new aspera-cli release

NewReleases is sending notifications on new releases.