github H2CK/oidc 2.6.1
Nextcloud OIDC Provider App - 2.6.1

5 hours ago

Nextcloud OpenID Connect Provider App - 2.6.1

This is the an OIDC App for Nextcloud. This application allows to use your Nextcloud Login at other services supporting OpenID Connect.

Provided features

  • Support for OpenID Connect Code (response_type = code) and Implicit (response_type = id_token) Flow - Implicite Flow must be activated per client
  • Support for the OAuth 2.0 Device Authorization Grant (RFC 8628)
  • Support for PKCE
  • Public and confidential types of clients are supported
  • Creation of ID Tokens and UserInfo responses with claims based on requested scopes and the OpenID Connect claims parameter (currently supported scopes: openid, profile, email, roles, groups, and offline_access)
  • Supported signing algorithms RS256 (default) and HS256
  • Group memberships can be passed as roles or groups claims
  • Clients can be assigned to dedicated user groups - Only users in the configured group are allowed to retrieve an access token to fetch the ID token
  • Support for RFC9068 JWT Access Tokens (must be activated per client)
  • Support for OAuth 2.0 Token Exchange (RFC 8693) using a constrained access-token-to-access-token profile
  • Discovery & WebFinger endpoint provided
  • RP-Initiated Logout, OpenID Connect Front-Channel Logout 1.0, Back-Channel Logout 1.0, and Session Management 1.0
  • Dynamic Client Registration
  • Client Configuration Management (RFC 7592)
  • Token Introspection (RFC 7662)
  • Access/refresh token revocation (RFC 7009)
  • Support for resource url (RFC 9728) at introspection
  • User Consent Management
  • Support for custom claims
  • Administration of clients via CLI
  • Generation and validation of access tokens using events
  • User specific settings to define which data is passed to clients in ID token and via userinfo endpoint

Full documentation can be found at:

User Documentation
Developer Documentation

What's Changed

  • Allow registering clients without a redirect URI by @cbcoutinho in #753
  • Build(deps-dev): Bump eslint from 10.12.0 to 10.13.0 by @dependabot[bot] in #754

Full Changelog: 2.6.0...2.6.1

Don't miss a new oidc release

NewReleases is sending notifications on new releases.