Bug Fixes
-
Don't assume program files folder locations
This checks where program files directories are located on a
Windows system, which are used for a fallback check aftergit
has not been found in aPATH
search (to invokegit
to find out
information such as the location of its system config file).Previously, two hard-coded paths were used. These were correct for
the vast majority of 64-bit Windows systems, but were in practice
never correct on 32-bit Windows systems. Checking programmatically
for the locations should thus enable detection to succeed on more
systems and under more circumstances, and avoid other problems.
Commit Statistics
- 35 commits contributed to the release over the course of 3 calendar days.
- 23 days passed between releases.
- 1 commit was understood as conventional.
- 0 issues like '(#ID)' were seen in commit messages
Commit Details
view details
- Uncategorized
- Merge branch 'program-files' (ffe6b60)
- Refactor (73ed340)
- Move
test::loc
'suse
statements up (dd53408) - Update/refine comments and do some minor cleanup (dea1746)
- Omit excess punctuation in
expect
messages (76e3b28) - Thanks clippy (464e0a2)
- Add second
super::
in non-Windowsalternative_locations
test (8ae54e8) - Don't assume program files folder locations (15235bf)
- Fix test bug generating expected value on 32-bit system (98db88b)
- Put the new tests in their own nested mod (d254e62)
- Rename helper, write its tests (and their helpers), fix a bug (e990bcd)
- Call fewer different things "suffixes" (de7c49f)
- Reorder statements in alternative_locations test for clarity (4d98535)
- Simplify path construction and config; improve comments (c8b2eb3)
- Add the missing
Git
component in the suffixes (1f0c3bf) - Remove a fixme that should no longer be done (00127a7)
- Rename helper; condense huge comment and move into position (df175bc)
- Fix the helper to join the
mingw*/bin
subdirs (c486a7d) - Start implementing a helper for ALTERNATIVE_LOCATIONS (167dc14)
- Narrow assert_architectures fixme to just what's left (e9eabeb)
- Adjust GitBinSuffixes so uses in the test method are clearer (671c476)
- Assert that the corresponding suffixes are correct (5258f7a)
- Assert
ALTERNATIVE_LOCATIONS
count and prefixes (dd1e5c8) - Rename PathsByRole to ProgramFilesPaths (3dd1d1f)
- Clarify what pf_current represents (95708dd)
- Make PathsByRole::maybe_pf_64bit an Option (5701145)
- Remove extra comment left over from before (518fd27)
- Improve expect and assert messages in PathsByRole::validate() (5df0cf5)
- Revise obtain_envlessly() doc comment for clarity (a5a5342)
- Do a minor simplification now that it's PathBuf (99a8eb3)
- Make ALTERNATIVE_LOCATIONS items PathBuf (5b206bc)
- Start on unit test for ALTERNATIVE_LOCATIONS (edc1351)
- Add dev dependencies for soon to be added unit test (6af59ca)
- Restyle just-changed and related code for clarity (98b3d90)
- Make ALTERNATIVE_LOCATIONS dynamic and OsString-based (9eaa0d9)