npm @storybook/addon-knobs 4.0.0-alpha.2
on Node.js NPM

2018-April-10

Also includes changes from 3.4.1

Breaking Changes

  • Change addon panel keyboard shortcut to shift-meta-z #3378
  • Move server/config to core #3261

Features

  • React native Typescript transform #3209
  • Split vendor and runtime chunk in static builds #3316
  • Persist background for @addon/background #3331
  • feat(notes): add marked options #3225

Bug Fixes

  • Enforce addons store being a singleton by storing it in global variable #3383
  • Scroll preview pane for non-percentage heights #3342
  • Scroll to top of the page when changing story #3338
  • Fix HtmlWebpackPlugin error #3328

Maintenance

  • Remove usages of deprecated React lifecycle methods #3327

Dependency Upgrades



142 Updates
  • Migrate to react-lifecycles-compat@3 #3392
  • Upgrade dev dependencies in Angular example #3391
  • Upgraded gatsby-remark-copy-linked-files in /docs from “1.5.30” to “1.5.31” #3388
  • Upgraded gatsby-source-filesystem in /docs from “1.5.28” to “1.5.29” #3388
  • Upgraded gatsby in /docs from “1.9.246” to “1.9.247” #3388
  • Upgraded lerna in / from “2.9.1” to “2.10.0” #3387
  • Upgraded babel-preset-minify in app/react from “0.3.0” to “0.4.0” #3387
  • Upgraded core-js in app/react from “2.5.4” to “2.5.5” #3387
  • Upgraded webpack-hot-middleware in app/react from “2.21.2” to “2.22.0” #3387
  • Upgraded webpack-dev-middleware in lib/core from “3.1.1” to “3.1.2” #3387
  • Upgraded webpack-hot-middleware in lib/core from “2.21.2” to “2.22.0” #3387
  • Upgraded core-js in app/angular from “2.5.4” to “2.5.5” #3387
  • Upgraded ts-loader in app/angular from “4.1.0” to “4.2.0” #3387
  • Upgraded webpack-hot-middleware in app/angular from “2.21.2” to “2.22.0” #3387
  • Upgraded zone.js in app/angular from “0.8.25” to “0.8.26” #3387
  • Upgraded babel-preset-minify in app/mithril from “0.3.0” to “0.4.0” #3387
  • Upgraded core-js in app/mithril from “2.5.4” to “2.5.5” #3387
  • Upgraded webpack-hot-middleware in app/mithril from “2.21.2” to “2.22.0” #3387
  • Upgraded @webcomponents/webcomponentsjs in app/polymer from “1.1.1” to “1.2.0” #3387
  • Upgraded babel-preset-minify in app/polymer from “0.3.0” to “0.4.0” #3387
  • Upgraded core-js in app/polymer from “2.5.4” to “2.5.5” #3387
  • Upgraded webpack-hot-middleware in app/polymer from “2.21.2” to “2.22.0” #3387
  • Upgraded babel-preset-minify in app/react-native from “0.3.0” to “0.4.0” #3387
  • Upgraded url-parse in app/react-native from “1.2.0” to “1.3.0” #3387
  • Upgraded webpack-dev-middleware in app/react-native from “3.1.1” to “3.1.2” #3387
  • Upgraded webpack-hot-middleware in app/react-native from “2.21.2” to “2.22.0” #3387
  • Upgraded babel-preset-minify in app/vue from “0.3.0” to “0.4.0” #3387
  • Upgraded core-js in app/vue from “2.5.4” to “2.5.5” #3387
  • Upgraded webpack-hot-middleware in app/vue from “2.21.2” to “2.22.0” #3387
  • Upgraded core-js in examples/angular-cli from “2.5.4” to “2.5.5” #3387
  • Upgraded zone.js in examples/angular-cli from “0.8.25” to “0.8.26” #3387
  • Upgraded @angular/cli in examples/angular-cli from “1.7.3” to “1.7.4” #3387
  • Upgraded @webcomponents/webcomponentsjs in examples/polymer-cli from “1.1.1” to “1.2.0” #3387
  • Upgraded webpack-dev-server in examples/polymer-cli from “3.1.1” to “3.1.3” #3387
  • Upgraded webpack-dev-server in examples/vue-kitchen-sink from “3.1.1” to “3.1.3” #3387
  • Upgraded lint-staged in / from “7.0.3” to “7.0.4” #3368
  • Upgraded webpack-dev-middleware in lib/core from “3.1.0” to “3.1.1” #3368
  • Upgraded webpack-dev-middleware in app/react-native from “3.1.0” to “3.1.1” #3368
  • Upgraded react in / from “16.3.0” to “16.3.1” #3357
  • Upgraded react-dom in / from “16.3.0” to “16.3.1” #3357
  • Upgraded react-test-renderer in / from “16.3.0” to “16.3.1” #3357
  • Upgraded react-dom in addons/centered from “16.3.0” to “16.3.1” #3357
  • Upgraded webpack in app/react from “4.4.1” to “4.5.0” #3357
  • Upgraded @types/react in addons/notes from “16.3.4” to “16.3.5” #3357
  • Upgraded react-test-renderer in addons/info from “16.3.0” to “16.3.1” #3357
  • Upgraded react in addons/links from “16.3.0” to “16.3.1” #3357
  • Upgraded react-dom in addons/links from “16.3.0” to “16.3.1” #3357
  • Upgraded webpack in lib/core from “4.4.1” to “4.5.0” #3357
  • Upgraded react in addons/storyshots from “16.3.0” to “16.3.1” #3357
  • Upgraded react-dom in addons/storyshots from “16.3.0” to “16.3.1” #3357
  • Upgraded react in app/angular from “16.3.0” to “16.3.1” #3357
  • Upgraded react-dom in app/angular from “16.3.0” to “16.3.1” #3357
  • Upgraded webpack in app/angular from “4.4.1” to “4.5.0” #3357
  • Upgraded zone.js in app/angular from “0.8.24” to “0.8.25” #3357
  • Upgraded react in app/mithril from “16.3.0” to “16.3.1” #3357
  • Upgraded react-dom in app/mithril from “16.3.0” to “16.3.1” #3357
  • Upgraded webpack in app/mithril from “4.4.1” to “4.5.0” #3357
  • Upgraded react in app/polymer from “16.3.0” to “16.3.1” #3357
  • Upgraded react-dom in app/polymer from “16.3.0” to “16.3.1” #3357
  • Upgraded webpack in app/polymer from “4.4.1” to “4.5.0” #3357
  • Upgraded webpack in app/react-native from “4.4.1” to “4.5.0” #3357
  • Upgraded react in app/vue from “16.3.0” to “16.3.1” #3357
  • Upgraded react-dom in app/vue from “16.3.0” to “16.3.1” #3357
  • Upgraded webpack in app/vue from “4.4.1” to “4.5.0” #3357
  • Upgraded zone.js in examples/angular-cli from “0.8.24” to “0.8.25” #3357
  • Upgraded protractor in examples/angular-cli from “5.3.0” to “5.3.1” #3357
  • Upgraded react in examples/cra-kitchen-sink from “16.3.0” to “16.3.1” #3357
  • Upgraded react-dom in examples/cra-kitchen-sink from “16.3.0” to “16.3.1” #3357
  • Upgraded react-scripts in examples/cra-kitchen-sink from “1.1.3” to “1.1.4” #3357
  • Upgraded webpack in examples/cra-kitchen-sink from “4.4.1” to “4.5.0” #3357
  • Upgraded webpack in examples/mithril-kitchen-sink from “4.4.1” to “4.5.0” #3357
  • Upgraded webpack in examples/polymer-cli from “4.4.1” to “4.5.0” #3357
  • Upgraded webpack in examples/vue-kitchen-sink from “4.4.1” to “4.5.0” #3357
  • Upgraded react in examples/official-storybook from “16.3.0” to “16.3.1” #3357
  • Upgraded react-dom in examples/official-storybook from “16.3.0” to “16.3.1” #3357
  • Upgraded gatsby-remark-autolink-headers in /docs from “1.4.15” to “1.4.16” #3356
  • Upgraded gatsby in /docs from “1.9.244” to “1.9.246” #3356
  • Upgraded danger in / from “3.4.4” to “3.4.5” #3350
  • Upgraded lint-staged in / from “7.0.2” to “7.0.3” #3350
  • Upgraded react-lifecycles-compat in addons/background from “1.1.1” to “1.1.4” #3350
  • Upgraded react-lifecycles-compat in addons/events from “1.1.1” to “1.1.4” #3350
  • Upgraded html-webpack-plugin in app/react from “3.1.0” to “3.2.0” #3350
  • Upgraded @types/react in addons/notes from “16.3.1” to “16.3.4” #3350
  • Upgraded axe-core in addons/a11y from “3.0.0” to “3.0.1” #3350
  • Upgraded react-lifecycles-compat in addons/info from “1.1.1” to “1.1.4” #3350
  • Upgraded react-lifecycles-compat in addons/knobs from “1.1.1” to “1.1.4” #3350
  • Upgraded react-lifecycles-compat in lib/ui from “1.1.1” to “1.1.4” #3350
  • Upgraded html-webpack-plugin in app/angular from “3.1.0” to “3.2.0” #3350
  • Upgraded html-webpack-plugin in app/mithril from “3.1.0” to “3.2.0” #3350
  • Upgraded html-webpack-plugin in app/polymer from “3.1.0” to “3.2.0” #3350
  • Upgraded html-webpack-plugin in app/react-native from “3.1.0” to “3.2.0” #3350
  • Upgraded html-webpack-plugin in app/vue from “3.1.0” to “3.2.0” #3350
  • Upgraded @types/node in examples/angular-cli from “9.6.1” to “9.6.2” #3350
  • Upgraded react-lifecycles-compat in examples/cra-kitchen-sink from “1.1.1” to “1.1.4” #3350
  • Upgraded react-scripts in examples/cra-kitchen-sink from “1.1.1” to “1.1.3” #3350
  • Upgraded html-webpack-plugin in examples/polymer-cli from “3.1.0” to “3.2.0” #3350
  • Update gatsby-source-filesystem in /docs from 1.5.27 to 1.5.28 #3349
  • Update gatsby in /docs from 1.9.243 to 1.9.244 #3345
  • Upgraded danger in / from “3.3.2” to “3.4.4” #3343
  • Upgraded eslint-plugin-import in / from “2.9.0” to “2.10.0” #3343
  • Upgraded lerna in / from “2.5.1” to “2.9.1” #3343
  • Upgraded lint-staged in / from “7.0.0” to “7.0.2” #3343
  • Upgraded react-lifecycles-compat in addons/background from “1.1.0” to “1.1.1” #3343
  • Upgraded react-lifecycles-compat in addons/events from “1.1.0” to “1.1.1” #3343
  • Upgraded react-textarea-autosize in addons/events from “6.1.0-0” to “6.1.0” #3343
  • Upgraded babel-plugin-react-docgen in app/react from “1.8.3” to “1.9.0” #3343
  • Upgraded nodemon in app/react from “1.17.2” to “1.17.3” #3343
  • Upgraded @types/react in addons/notes from “16.1.0” to “16.3.1” #3343
  • Upgraded react-lifecycles-compat in addons/info from “1.1.0” to “1.1.1” #3343
  • Upgraded moment in addons/knobs from “2.21.0” to “2.22.0” #3343
  • Upgraded react-lifecycles-compat in addons/knobs from “1.1.0” to “1.1.1” #3343
  • Upgraded react-textarea-autosize in addons/knobs from “6.1.0-0” to “6.1.0” #3343
  • Upgraded react-lifecycles-compat in lib/ui from “1.1.0” to “1.1.1” #3343
  • Upgraded serve-favicon in lib/core from “2.4.5” to “2.5.0” #3343
  • Upgraded zone.js in app/angular from “0.8.20” to “0.8.24” #3343
  • Upgraded nodemon in app/angular from “1.17.2” to “1.17.3” #3343
  • Upgraded nodemon in app/mithril from “1.17.2” to “1.17.3” #3343
  • Upgraded nodemon in app/polymer from “1.17.2” to “1.17.3” #3343
  • Upgraded ws in app/react-native from “5.1.0” to “5.1.1” #3343
  • Upgraded nodemon in app/vue from “1.17.2” to “1.17.3” #3343
  • Upgraded react-lifecycles-compat in examples/cra-kitchen-sink from “1.1.0” to “1.1.1” #3343
  • Upgraded zone.js in examples/angular-cli from “0.8.20” to “0.8.24” #3343
  • Migrate to axe-core@3.0.0 #3332
  • Migrate to ws@5 #3334
  • Upgraded @storybook/addon-actions in /docs from “3.3.15” to “3.4.0” #3325
  • Upgraded @storybook/addon-links in /docs from “3.3.15” to “3.4.0” #3325
  • Upgraded @storybook/addons in /docs from “3.3.15” to “3.4.0” #3325
  • Upgraded @storybook/react in /docs from “3.3.15” to “3.4.0” #3325
  • Update gatsby-remark-autolink-headers in /docs from 1.4.13 to 1.4.15 #3314
  • Upgraded webpack in app/react from “4.3.0” to “4.4.1” #3315
  • Upgraded webpack in lib/core from “4.3.0” to “4.4.1” #3315
  • Upgraded webpack in app/angular from “4.3.0” to “4.4.1” #3315
  • Upgraded webpack in app/mithril from “4.3.0” to “4.4.1” #3315
  • Upgraded webpack in app/polymer from “4.3.0” to “4.4.1” #3315
  • Upgraded webpack in app/react-native from “4.3.0” to “4.4.1” #3315
  • Upgraded webpack in app/vue from “4.3.0” to “4.4.1” #3315
  • Upgraded webpack in examples/cra-kitchen-sink from “4.3.0” to “4.4.1” #3315
  • Upgraded @types/node in examples/angular-cli from “9.6.0” to “9.6.1” #3315
  • Upgraded webpack in examples/mithril-kitchen-sink from “4.3.0” to “4.4.1” #3315
  • Upgraded webpack in examples/polymer-cli from “4.3.0” to “4.4.1” #3315
  • Upgraded webpack in examples/vue-kitchen-sink from “4.3.0” to “4.4.1” #3315
  • Add babel-core dev-deps #3319

2 years ago