npm @storybook/addon-knobs 3.4.0-alpha.6
on Node.js NPM

2018-January-27

Features

  • Pass default webpack config as third argument in Full Control Mode #2796

Bug Fixes

  • Angular: remove entryComponents prop from metadata #2790
  • Use process.exitCode instead of process.exit() #2717

Documentation

  • Extending webpack section is no longer needed for the common usage #2826
  • Updating Vue Jest Config #2821
  • Angular inheritance example #2787

Maintenance

Dependency Upgrades



76 Upgrades
  • Upgraded eslint-plugin-react in / from “7.5.1” to “7.6.0” #2844
  • Upgraded lint-staged in / from “6.0.1” to “6.1.0” #2844
  • Upgraded react-native in app/react-native from “0.52.1” to “0.52.2” #2844
  • Upgraded @angular/cli in examples/angular-cli from “1.6.5” to “1.6.6” #2844
  • Upgraded protractor in examples/angular-cli from “5.2.2” to “5.3.0” #2844
  • Upgraded gatsby-plugin-sharp in /docs from “1.6.26” to “1.6.27” #2843
  • Upgraded gatsby-remark-images in /docs from “1.5.40” to “1.5.41” #2843
  • Upgraded gatsby-source-filesystem in /docs from “1.5.14” to “1.5.15” #2843
  • Upgraded gatsby in /docs from “1.9.166” to “1.9.169” #2843
  • Upgraded @types/lodash in / from “4.14.95” to “4.14.96” #2840
  • Upgraded airbnb-js-shims in app/angular from “1.4.0” to “1.4.1” #2840
  • Upgraded airbnb-js-shims in app/polymer from “1.4.0” to “1.4.1” #2840
  • Upgraded airbnb-js-shims in app/react from “1.4.0” to “1.4.1” #2840
  • Upgraded airbnb-js-shims in app/vue from “1.4.0” to “1.4.1” #2840
  • Upgraded @angular/animations in examples/angular-cli from “5.2.1” to “5.2.2” #2840
  • Upgraded @angular/common in examples/angular-cli from “5.2.1” to “5.2.2” #2840
  • Upgraded @angular/compiler in examples/angular-cli from “5.2.1” to “5.2.2” #2840
  • Upgraded @angular/core in examples/angular-cli from “5.2.1” to “5.2.2” #2840
  • Upgraded @angular/forms in examples/angular-cli from “5.2.1” to “5.2.2” #2840
  • Upgraded @angular/http in examples/angular-cli from “5.2.1” to “5.2.2” #2840
  • Upgraded @angular/platform-browser in examples/angular-cli from “5.2.1” to “5.2.2” #2840
  • Upgraded @angular/platform-browser-dynamic in examples/angular-cli from “5.2.1” to “5.2.2” #2840
  • Upgraded @angular/router in examples/angular-cli from “5.2.1” to “5.2.2” #2840
  • Upgraded @angular/compiler-cli in examples/angular-cli from “5.2.1” to “5.2.2” #2840
  • Upgraded @angular/language-service in examples/angular-cli from “5.2.1” to “5.2.2” #2840
  • Upgraded gatsby-plugin-sharp in /docs from “1.6.25” to “1.6.26” #2828
  • Upgraded gatsby-remark-images in /docs from “1.5.39” to “1.5.40” #2828
  • Upgraded gatsby in /docs from “1.9.165” to “1.9.166” #2828
  • Upgraded @types/lodash in / from “4.14.93” to “4.14.95” #2829
  • Upgraded vue-style-loader in app/vue from “3.0.3” to “3.1.1” #2829
  • Upgraded karma-coverage-istanbul-reporter in examples/angular-cli from “1.3.3” to “1.4.1” #2829
  • Upgraded vue-style-loader in examples/vue-kitchen-sink from “3.0.3” to “3.1.1” #2829
  • Upgraded @webcomponents/webcomponentsjs in app/polymer from “1.0.22” to “1.1.0” #2818
  • Upgraded enzyme-to-json in addons/storyshots from “3.3.0” to “3.3.1” #2818
  • Upgraded @webcomponents/webcomponentsjs in examples/polymer-cli from “1.0.22” to “1.1.0” #2818
  • Upgraded @types/jasmine in examples/angular-cli from “2.8.4” to “2.8.5” #2818
  • Upgraded enzyme-to-json in examples/cra-kitchen-sink from “3.3.0” to “3.3.1” #2818
  • Upgraded enzyme-to-json in examples/official-storybook from “3.3.0” to “3.3.1” #2818
  • Upgraded react-chromatic in examples/official-storybook from “0.7.8” to “0.7.9” #2818
  • Upgraded gatsby-transformer-remark in /docs from “1.7.28” to “1.7.29” #2816
  • Upgraded gatsby in /docs from “1.9.164” to “1.9.165” #2816
  • Upgraded eslint in / from “4.15.0” to “4.16.0” #2806
  • Upgraded github-release-from-changelog in / from “1.3.0” to “1.3.1” #2806
  • Upgraded jest in / from “22.1.3” to “22.1.4” #2806
  • Upgraded jest-cli in / from “22.1.3” to “22.1.4” #2806
  • Upgraded jest-config in / from “22.1.3” to “22.1.4” #2806
  • Upgraded jest-environment-jsdom in / from “22.1.2” to “22.1.4” #2806
  • Upgraded jest-jasmine2 in / from “22.1.3” to “22.1.4” #2806
  • Upgraded lerna in / from “2.6.0” to “2.8.0” #2806
  • Upgraded lint-staged in / from “6.0.0” to “6.0.1” #2806
  • Upgraded shelljs in / from “0.8.0” to “0.8.1” #2806
  • Upgraded shelljs in addons/links from “0.8.0” to “0.8.1” #2806
  • Upgraded glamorous in lib/components from “4.11.3” to “4.11.4” #2806
  • Upgraded glamorous in addons/a11y from “4.11.3” to “4.11.4” #2806
  • Upgraded glamorous in addons/info from “4.11.3” to “4.11.4” #2806
  • Upgraded glamorous in addons/jest from “4.11.3” to “4.11.4” #2806
  • Upgraded shelljs in app/angular from “0.8.0” to “0.8.1” #2806
  • Upgraded shelljs in app/polymer from “0.7.8” to “0.8.1” #2806
  • Upgraded shelljs in app/react-native from “0.8.0” to “0.8.1” #2806
  • Upgraded react-native in app/react-native from “0.52.0” to “0.52.1” #2806
  • Upgraded glamorous in app/react from “4.11.3” to “4.11.4” #2806
  • Upgraded shelljs in app/react from “0.8.0” to “0.8.1” #2806
  • Upgraded shelljs in app/vue from “0.8.0” to “0.8.1” #2806
  • Upgraded webpack-dev-server in examples/polymer-cli from “2.11.0” to “2.11.1” #2806
  • Upgraded shelljs in lib/cli from “0.8.0” to “0.8.1” #2806
  • Upgraded jasmine-core in examples/angular-cli from “2.9.0” to “2.9.1” #2806
  • Upgraded glamorous in examples/cra-kitchen-sink from “4.11.3” to “4.11.4” #2806
  • Upgraded jest in examples/cra-kitchen-sink from “22.1.3” to “22.1.4” #2806
  • Upgraded webpack-dev-server in examples/vue-kitchen-sink from “2.11.0” to “2.11.1” #2806
  • Upgraded @storybook/addon-actions in /docs from “3.3.9” to “3.3.10” #2799
  • Upgraded @storybook/addon-links in /docs from “3.3.9” to “3.3.10” #2799
  • Upgraded @storybook/addons in /docs from “3.3.9” to “3.3.10” #2799
  • Upgraded @storybook/react in /docs from “3.3.9” to “3.3.10” #2799
  • Upgraded gatsby-remark-images in /docs from “1.5.37” to “1.5.39” #2799
  • Upgraded gatsby-source-filesystem in /docs from “1.5.11” to “1.5.14” #2799
  • Upgraded gatsby in /docs from “1.9.158” to “1.9.164” #2799

2 years ago