"use strict" and "use warnings" everywhere.
Reformat some if the code according to the "perlstyle" man page. It makes
the code easier for read, for me at least.Add descriptions to tests.
Reorder CHANGES to chronological order.
Use bpi() as a class method, not a function.
Replace "use vars ..." with "our ...".
More descriptive variable names.
Start POD sections with =pod
Allow "nan", "inf", and "infinity", and ingore case, since core Perl allows
these. We want to be compatible. Add tests to "infnan.inc".