github Quick/Quick v1.2.0
on GitHub

This release fully supports Xcode 9 (both Swift 3.2 and Swift 4) and still works with Xcode 8.3 + Swift 3.1! 🎉

New Features

  • Introduce Behavior<Context> #701 (Thanks @mosamer)
  • Support Xcode 9 / Swift 4 #711, #721, #730, #735 (Thanks @ikesyo, @sharplet)

Changes

  • Performance improvment for large test suites #697 (Thanks @dbarden)
  • Better conformance to SwiftLint (Thanks @ecylo, @ikesyo, @nasakinmaxim, @wongzigii)

Documentation Changes

  • Fix japanese document typo #738 (Thanks @AcaiBowl)

Bugfixes

  • SwiftLint will be executed only on builds for testing #694 (Thanks @nerd0geek1)
  • Fix SwiftPM integration with generated Xcode projects #708 (Thanks @ikesyo)
  • Fix SPM integration #746 (Thanks @sunshinejr)
2 years ago